We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Signed Emails with Attachments - Certificate Error

I am using Aspose.Email.dll version 6.4 and could still reproduce the issue ‘EMAILNET-35181’. This issue occurs when sending a Signed message with attachments. I get the message and the attachment delivered Okay but when I click on the Signature, I could see the error “The message contents may have been altered.<span style=“font-size:12.0pt;font-family:“Times New Roman”,“serif”;
mso-fareast-font-family:Calibri;mso-fareast-theme-font:minor-latin;mso-ansi-language:
EN-GB;mso-fareast-language:EN-GB;mso-bidi-language:AR-SA”>” I have attached the certificate on the email for your reference.

Hi Sathyapriya,

Thank you for contacting Aspose Support team.

The issue seems to be linked with EMAILNET-35181 that was created with existing messages loaded from disc. We have tested it and the issue has been fixed. However, the problem arises when a new message is created using the Aspose.Email API. Can you please confirm to us if you are facing the same behavior of the API?

Yes, We are creating the message using Aspose.Email

Hi Sathyapriya,

Thank you for sharing your feedback.

Though the issue seems similar to EMAILNET-35181, we have logged it as EMAILNET-35207 where the issue is reproducible when a new message is created and signed. We’ll update you here once there is some information available in this regard.

Please let me know if you have an ETA for the fix.

Hi Sathyapriya,

The issue has been fixed and the fix version will be available for download in second week of next month i.e. May 2016. We’ll update you here once there is some information available in this regard.

The issues you have found earlier (filed as EMAILNET-35207) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.