We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Signing PDF always failed

To Reproduce:

1. Unzip attached file and open the solution file in VS 2010
2. Execute it (NOTE: change TestPath to the right folder)

BUG: It fails at the last line with error message:

CryptographicException was unhandled
Bad Data

I did try other PDF files, it always failed. Any idea?


Thanks,
Tony

Hi Tony,

I have reproduced this issue at my end and logged it as PDFKITNET-21231 in our issue tracking system. Our team will look into this issue and you’ll be updated via this forum thread once it is resolved.

We’re sorry for the inconvenience.
Regards,

We have now the same problem - i licensed the Aspose Total .NET toolkit end of last year and now i relize that 2 functions which we tried to use in our projects does not work

- it is not possible to sing a PDF document

We have implemented a sample project, but we get an exception, the same that we found here:

Attached you this sample project to reproduce this exception.

In the root folder I put the certificate used for test (bianca.pfx, with password: bianca).

- it is not possible to load XFDF to a PDF form

<A href="</A> </P> <P>There is no informaiton if and when this bugs will be solved - these are basic functions of the toolkit and we decided to license the toolkit because it looks that there are a lot of useful functions but more and more i find out that (also when reading this forum) that a lot of functions have problems or are not usable.</P> <P>It is not the sense to license a tookit and then to find then out that we have to search for other solutions to get a working software.</P> <P><STRONG>Was it a wrong descision to select ASPOSE ?</STRONG></P> <P><STRONG>When will these problems fixed ?</STRONG></P> <P><STRONG>Why functions are listed on the web-site as feature which are not working ?</STRONG></P> <P> </P> <P> </P>

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

First of all, please accept our apologies for the inconvenience.

wmay:
it is not possible to sing a PDF document

I tried your sample application to add signature to a PDF file using your provided certificate file with the latest version of Aspose.Pdf for .NET v6.7 and it seems that the password you have provided is incorrect. I am not able to edit the certificate using that password in windows. Then, I used another certificate file with your sample application and it works fine. For sack of testing, I tested with the wrong password with that certificate using your sample application and it gave me same exception “Bad Data” as reported by you. So, I think the issue may be the wrong password. Please check it at your end and let me know if you are able to use the same certificate with the password provided in windows. If there is a different password, please share it with us and we will further look into this issue.

wmay:
- it is not possible to load XFDF to a PDF form

I have asked the development team to share an ETA regarding this issue. As soon as I get a response, I will update you in the relevant thread.

wmay:
Was it a wrong descision to select ASPOSE ?

We are sorry for the inconvenience. Our products provide excellent features for the customers and we are committed to provide best support to our customers. We are regularly providing support for new features and in case there is some issue in our products, we try to fix that issue as soon as possible.

wmay:
When will these problems fixed ?

I have replied above regarding both the issue.

wmay:
Why functions are listed on the web-site as feature which are not working ?

Well, we try to test all the features before releasing them for the customers. But some scenarios differ from customer to customer and there are possibilities of features not working in some particular scenario. However, we try to fix such issues as soon as possible. Now, regarding Aspose.Pdf for .NET, as we have merged the two products, so we did receive issues from our clients but our development team has worked really hard in rectifying those issues and each of our release comes up with new features, features enhancements and bug fixes as per customer needs.

We are very sorry for the inconvenience,

Hi,

Thank you for your fast response - i used an own generated certificate with my own password and tried this sample and it works also - so it seems that all works fine and that there is a problem with the certificate.

I have to check this with our developers why the test certificate from them does not work - maybe a problem with the password.

hope the other problem with the forms data loading will be solved soon.

best regards

Wolfgang