We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Slide Cloning Error in aspose-slides-2.0.0.4

Have been hitting a slide cloning error in multiple presentations:

com.aspose.slides.PptEditException: Slide cloning error.
at com.aspose.slides.Presentation.cloneSlide(SourceFile:1649)
at com.altuscorp.tests.PPTest.main(PPTest.java:46)
Caused by: com.aspose.slides.PptEditException: Slide cloning error.
at com.aspose.slides.Presentation.cloneSlide(SourceFile:1515)
at com.aspose.slides.Presentation.cloneSlide(SourceFile:1547)
… 1 more
Caused by: java.lang.ArrayIndexOutOfBoundsException: 26863
at com.aspose.slides.obfuscated.ut.do(SourceFile:449)
at com.aspose.slides.obfuscated.ut.do(SourceFile:288)
at com.aspose.slides.obfuscated.fm.do(SourceFile:46)
at com.aspose.slides.obfuscated.wq.do(SourceFile:85)
at com.aspose.slides.obfuscated.wq.do(SourceFile:85)
at com.aspose.slides.obfuscated.wq.do(SourceFile:85)
at com.aspose.slides.obfuscated.wq.do(SourceFile:85)
at com.aspose.slides.obfuscated.wq.do(SourceFile:85)
at com.aspose.slides.obfuscated.wq.do(SourceFile:85)
at com.aspose.slides.Slide.do(SourceFile:527)
at com.aspose.slides.Presentation.do(SourceFile:1440)
at com.aspose.slides.Presentation.cloneSlide(SourceFile:1511)
… 2 more


am attaching a ppt in which the 2nd slide(of 2) causes the error. Any chance you could let me know a good workaround for this or when a fix is forthcoming?

any word on this? this is fairly urgent as it is holding up delivery of a product.

Hello,

The problem is reproduced but we didn’t find why it happens yet. We will try to fix it before Monday and will let you know as soon as new version will be available.

thank you so much! look forward to the fix and let me know if you need any additional data.

Hello,

The problem was fixed. I have updated 2.0.0 release main downloads with 2.0.0.5 version of Aspose.Slides for Java. Please try it.

pulling it down and giving it a run - will let you know the results. thanks for the quick turnaround on this :slight_smile:

appears to have fixed this issue. thanks so much. any word on the getThumbnail and pptx cloning issues that still seem to exist in this latest build? links to threads are:

getThumbnail exceptions in aspose.slides 2.0.0.4

Pptx addClone in java - multiple issues - 2.0.0.4

unfortunately both of these are causing us some major problems as well.

The issues you have found earlier (filed as 10913) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(1)