We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Slide formatting with Chinese characters

Hi,


I have a powerpoint with a mix of Chinese and English characters but it seems like it does not fill the full width of the page like the original slides when I save it as PDF. File is attached - both the original and the PDF.

Here are my slide settings - let me know if there’s something I need to tweak or change!

public void convertSlides() {
System.out.println(“Started conversion.”);
long startTime = System.currentTimeMillis();

PdfOptions pdfSaveOptions = new com.aspose.slides.PdfOptions();
pdfSaveOptions.setEmbedFullFonts(false);
pdfSaveOptions.setEmbedTrueTypeFontsForASCII(true);
pdfSaveOptions.setTextCompression(com.aspose.slides.PdfTextCompression.None);
pdfSaveOptions.setJpegQuality((byte) 100);
pdfSaveOptions.setCompliance(com.aspose.slides.PdfCompliance.Pdf15);
pdfSaveOptions.setSaveMetafilesAsPng(true);
pdfSaveOptions.setSufficientResolution(128);

try {
FileInputStream fis = new FileInputStream(SOURCE_PATH);

Presentation doc = new Presentation(fis);
doc.save(TARGET_PATH, SaveFormat.Pdf, pdfSaveOptions);

} catch (Exception e) {
System.err.println("Error during conversion - " + e.getMessage());
} finally {
long endTime = System.currentTimeMillis();
System.out.println("Finished conversion (total time = " + String.valueOf(endTime - startTime) + “ms)”);
}
}

Hi,


Thank you for posting.

I have observed your comments and have worked with the presentation file shared by you. I have not been able to reproduce the issue as the PDF is generated exactly as the pptx file. I have attached the generated output file (see chinese_PDF.pdf) for your kind reference. I request you to please try using Aspose.Slides for Java 15.10.0 on your end and then share your kind feedback with us.

Please let us know if the issue persists. We will be happy to assist you further.

Best Regards,

Hi - I have tried with 15.10.0 but I still seem to get cropping of the characters. See attached file.


Can you let me know what slide settings you are using? Is it the same as my original code above?

Here’s a zip of the stand-alone class that I used to generate the PDF, you will need to add in your paths at the top to run it.

Hi,


I have observed your comments and like to share with you that I have used exactly the same code, as shared by you, to generate the PDF. I request you to please share with us the environment details on your end so that we may investigate it further to help you out.

Best Regards,

I am on a MacBook Air running OSX 10.10.2.


I have Slides 15.10.0 and am running Java 1.8.0_25.

I am also running PowerPoint for Mac 2011 (version 14.2.5).
Hi,

I have observed your comments and worked with the presentation file shared by you. I have been able to reproduce the issue while working with OSX. A ticket with ID SLIDESJAVA-35143 has been logged in our issue tracking system to further investigate and resolve the issue.This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

Thanks - for the record, I see the same issue occuring in Ubuntu and CentoOS linux distributions. Is it something to do with the fonts? If you are running on a Windows machine you will have all the Microsoft fonts available too. I could not find information on configuring fonts in your documentation for Aspose Slides (it seems like it’s different to Aspose Words).

Hi,


I have observed your comments and like to share with you that I have updated the information about the issue in our issue management system. I request you to please visit this documentation article to see how to load fonts externally.

Please share if I may help you further in this regard.

Best Regards,

The issues you have found earlier (filed as SLIDESJAVA-35143) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.