Free Support Forum - aspose.com

Slide thumbnail: The process hang for ever on getting images (Java)

Hi,

We’re facing a strange scenario in which the attached presentation, we’re unable to get the thumbnail of the second slide. It hangs endlessly. Problem is only in Linux, works well in Windows. When removing the picture from the second slide it works well.
test123-1.zip (2.9 MB)

Please advise,

Oren

@oren.shoham,

I have observed the issue shared by you and request you please share the generated output file with us. However, before sharing the information, please first try using latest Aspose.Slides for Java 19.12 on your end as well. Please also share the used sample codes with you.

Hi, we tried upgrading to 19.12 (Linux Only) but the problem persists.
Here is the sample code:

for (int i = 0; i < presentation.getSlides().size(); i++) {

        ByteArrayInputStream bis = null;
        ByteArrayOutputStream buffer = null;
        try {
            l
            ISlide slide = presentation.getSlides().get_Item(i);
            BufferedImage image = slide.getThumbnail(2f, 2f);
            buffer = new ByteArrayOutputStream();
            ImageIO.write(image, "jpeg", buffer);
            bis = new ByteArrayInputStream(buffer.toByteArray());

        } finally {

            if (buffer != null)
                buffer.close();
            if (bis != null) {
                bis.close();
            }
        }
    }

@oren.shoham,

I have observed the information shared by you and have created an issue with ID SLIDESJAVA-38007 in or issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

@oren.shoham,

We have tried to reproduce this issue on Ubuntu and CentOS with Oracle and OpenJDk and have not been able to reproduce that using Aspose.Slides for Java 20.1. Can you please try using the specified version.

In case the issue persisit, please share your following environment details:

  1. OS name and version
  2. jdk version
  3. java args