Free Support Forum - aspose.com

Slides 6.7.1: save/write not possible: java.lang.AssertionError: Cannot read a name from the name table in a font

Hi there,

I just upgraded to aspose slides version 6.7.1 (from 2.9) and I’m running into a serious problem with the easiest of all samples.

I’m just trying to create a presentation and save it, but I always get the following error message:
"java.lang.AssertionError: Cannot read a name from the name table in a font."

I didn’t do anything with the new FontsLoader yet, my source is just this:

final PresentationEx pres = new PresentationEx();
pres.save(“C:\_temp\test.pptx”);

I also tried with different save and write functions, but it’s always the same.
Do I need any additional library or specific java version to get it to work?

Thanks in advance,
Christiane

Hi Christiane,


Thanks for inquiring Aspose.Slides.

I like to share that the similar issues have been reported when Aspose.Slides for Java 6.7.x is used in Unix or Linux environment. The said issue has been resolved in Aspose.Slides for Java 6.9.0 that has just been released. Please try using the specified latest version and if there is still an issue then please share your feedback with us. Please also share the platform information along with JDK version used for further investigation in case if the issue is still reproducible on your end with new version.

Many Thanks,

Hi!
I tried the same with version 6.9.0 and still get the same error.
I’m on a Windows 7 (64bit) machine, and using Java 1.6 for the project.

Are there any Eclipse settings that might be responsible for that?
We really need to fix this soon, otherwise we won’t be able to do a version upgrade for our project this year.

With regards,
Christiane Eckl

Hi Christiane Eckl,


I like to share that I have Windows 7 x64 on my end and installed with jdk1.6.0_27. There are no settings for Eclipse and all you need is to include Aspose.Slides for Java jar file. I have shared the generated presentation and sample Eclipse project for your kind reference that works on my end without any issue.

Many Thanks,

Hi!

After testing the sample on different windows 7 (x64) machines, I discovered that it was working everywhere but on my PC.

Finally I found out that the error message was to be accepted at face value - I had a corrupt font file installed that Aspose could not handle. Apparently Aspose scans through all the windows fonts when creating a new Presentation which resulted in the error message above. Deleting the font did the trick.

So my issue is resolved and I can go on with my tests.

Thanks,
Christiane Eckl

Hi Christiane Eckl,


That is appreciable that you have been able to identify and resolve the issue on your end. Please share if I may help you further in this regard.

Many Thanks,