Slides Macro issues using Aspose.Slides for .NET


Our users reported that after Aspose processing of macro enabled Powerpoint files, the PowerPoint app shows that the macro project is somewhat corrupt, or different at least. I attached 2 sample files (before processing and after) , and screenshot of the error dialogs. If the users presses continue on error, the project is loaded, but I think that since Aspose is not able to execute macros, it should not touch that section of the file. The output file is correct though, but I would like to know the exact implications of these differences, so I know what to guarantee to our users.aspose (177.5 KB)

The sample code to reproduce the issue:

Aspose.Slides.Presentation document = new Aspose.Slides.Presentation(filePath);
document.Save(filePath, Aspose.Slides.Export.SaveFormat.Pptm);



I have worked with source file and sample code shared by you using Aspose.Slides for .NET 18.11. For further investigation, can you please share which PowerPoint version you used to open the VBA Project macroses.

PowerPoint 2016
Version 1811 Build 11029
And latest Aspose.Slides for .Net 18.11.


I have worked with the presentation shared by you using Aspose.Slides for .NET 18.11.0 and have been able to observe the issue. A ticket with ID SLIDESNET-40715 has been added in our issue tracking system to resolve the issue. This thread has been associated with the ticket so that we share notification with you once issue will be fixed.

The issues you have found earlier (filed as SLIDESNET-40715) have been fixed in this update.