Free Support Forum - aspose.com

Slides/PDF license does not work when Fips is disabled

If I attempted to export as a PDF on server 2012 I am thrown an error pertaining to FIPS compliance.
I cannot disable Fips complaiance. the only around this for now is to disable in app.config
<runtime> <enforceFIPSPolicy enabled="false"/> </runtime>

When this is set, I can successfully export the PDF, however I have the evaluation message printed on all slides. Whether I set a PDF license, or a Slides License, or both - the message never goes away.

public Stream ExportPdf(ISaveOptions options)
{
//var slidesLic = new Aspose.Slides.License();
//slicesLic.SetLicense(AsposeLicense.LicenseFile);

        try
        {
            Aspose.Pdf.License lic = new Aspose.Pdf.License();
            lic.SetLicense(AsposeLicense.LicenseFile);
            Stream exportStream = new MemoryStream();
            _presentation.Save(exportStream, SaveFormat.Pdf);
            exportStream.Position = 0;
            return exportStream;
        }
        catch (Exception e)
        {
            ErrorStatus = true;
            Message = "PPT Err:" + e.Message;
            Console.WriteLine(Message + e.InnerException);
            return null;
        }
    }

@rileyja,

It seems to be a mistake in your code. You are calling Aspose.PDF license rather Aspose.Slides. Can you please verify.