We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SmartTags are showed in xls when there is no data in datasource

Aspose Cells 1.9.2 Java

I use SmartTags for datasouce (&=dataSource.propertyName). DataSource is AsposeDataTable object.
When there are data in AsposeDataTable everything is fine (ie. tags are processed). But when there are no data (ie. first call of AsposeDataTable.next() returns false) SmartTags are not processed - they are preserved in resulting excel file. I expected tags are erased in resulting file no matter if there are any data in datatable…

Is there some way how I can force Aspose to behave so?

Thank you.


Please try this attached fix. If have not set datasource for SmartMarker or there is no data in datasource, we will keep the SmartTags or not, according to the "isPreserve" flag of method WorkbookDesigner.process(boolean isPreserve). For your case, please use process(false).


thanks for quick response. Using of isPreserve flag was first thing that came up in my mind, but it didn’t work. I updated my version of Aspose Cells to version you send through attachment, but it doesn’t work neither.


I tested the version sent to you, attachment in this post includes my test code and template, the SmartMarker_F.xls and SmartMarker_T.xls are the result created with "isPreserve" flag false or true separately. If it is not similar to your case, please send us your sample code and template, thank you.

And in my code I printed the version of Aspose.Cells, the version I sent to you should be, please check and make sure you use the proper version.

I found out that there is problem in my template excel file. But I am not sure what is wrong.
The template file is in attachment… Thank you very much…

any progression? sorry for this post, but it seems you forget so…

Sorry, it seems that we didn’t notice your post. We will check your file and reply soon.


Sorry for missing read your new post on this topic, and thank you for being patient. Please try this fix, I have tested it with your template, I think it fits your requirement now.


fix is ok, good work guys. Best wishes…