Free Support Forum - aspose.com

SmtpClient & PostFix 2.8's Pre-greet

After a lot of researching we finally found out why the default .NET SmtpClient and (most likely) the Aspose SmtpClient sometimes fail with a timeout to some smtp-servers. It seems both are failing on a feature of Postfix 2.8 (and higher) called “Pre-greet”.


Normally all mail servers will start with:
"220 mail.something.whatever ESMTP Something"

However, when Pre-greet is enabled, a Postfix server will start it’s greet with:
"220-mail.something.whatever ESMTP Postfix"
And about 5-20s later will send the normal greet:
"220 mail.something.whatever ESMTP Postfix"

It seems the SmtpClient either responds too soon (e.g. on the invalid 220-message) or gets confused. After that, the mail connection will wait until the timeout is reached.

To test this bug you can try to send an email to the following E-mail address:
noreply@online.nl

Using their SMTP server:
smtp-in.online.nl

You’ll find out that you can’t send an email to supplied email address because the SmtpClient fails on the Pre-greet.

More info in a MS-bug report:
<span style=“font-size:11.0pt;font-family:“Calibri”,“sans-serif”;
mso-fareast-font-family:Calibri;mso-fareast-theme-font:minor-latin;mso-ansi-language:
NL;mso-fareast-language:NL;mso-bidi-language:AR-SA”>http://connect.microsoft.com/VisualStudio/feedback/details/685280/system-net-mail-smtpclient-fails-to-send-to-postfix-when-pre-greet-filter-is-enabled

Info about Postfix Pre-greet:
http://www.postfix.org/POSTSCREEN_README.html#pregreet

Regards, Jerremy

Hi Jerremy,


Thank you for sharing your research findings with us.

In order to test this issue in accordance with the SMTP implementation at Aspose.Email end, I have logged this issue in our issue tracking system for further investigation by our development team. We will update you here once we have any information in this regard.

The issue has been logged in our issue tracking system as: NETWORKNET-33495.

Hi Jerremy,


We are currently investigating this issue to fix it, and need your assistance in this regard. Since online.nl is not a public server, we don’t have a test account on this server and can’t investigate this issue further. Can you please arrange a test account on this server for us, so that we can further investigate this issue? We will then look into this issue further and complete our investigate for possible resolution. Your cooperation in this regard is highly appreciated.

I’m sorry but I do not have access to a private PostFix server, neither do I have contacts at @online.nl . I only know that the issue is due to the Pre-Greet in PostFix 2.8+ .


I’m pretty sure you can send email to noreply@online.nl without consequence though. It’s the email address that we used to test this bug.

If that’s not what you’re looking for then I suggest installing PostFix and turning on the feature.

Hi Jerremy,


Thank you for the feedback.

We will look into this and, if needed, will contact you again if further clarification is required.

The issues you have found earlier (filed as NETWORKNET-33495) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.