Something does not work in Cells?


#1

Hi,

1) I defined this format “# ##0;(# ##0)” to Style.Custom of one cell, but the format is rendered in Excel in format : “#\ ##0;(#\ ##0)”.

2) I wrote this code : chart.SecondValueAxis.Title.TextFont.IsBold = true, but the title is not appeared in bold, same for the title color and the title rotation (-90). On the contrary, they work well for the first Y-Axis.


Thanks for your response.


#2

1) I used the following sample code and don't find any problem:

Workbook workbook = new Workbook();
workbook.Worksheets[0].Cells["A1"].Style.Custom = "# ##0;(# ##0)";
workbook.Save("d:\\test\\abc.xls");

Which version of Aspose.Cells are you using?

2) I will check this issue soon.


#3

We are using Cells 4.0.

i used this code :
Workbook workbook = new Workbook();
workbook.Worksheets[0].Cells[“A1”].Style.Custom = “# ##0;(# ##0)”;
workbook.Worksheets[0].Cells[“A1”].PutValue(2000000);
workbook.Save(System.IO.Path.GetTempPath() + “abc.xls”);

and in the output Excel file, it add “” before the blank space and the number is like “2000 000”.

Please see in attachment file.

Thanks.


#4

I don't find your attached file. I run your code and attach the output file.

1. I don't find a "\" in MS Excel.

2. In MS Excel, if you format a cell with custom format "# ##0;(# ##0)" manually, you will find the number is formated as "2000 000".


#5

And this is the screenshot of this Excel file.


#6

ok, i found it, because in Franch, the seperator is " ", but in English is “,”, so i changed to “#,##0;(#, ##0)”, and then it works. Same for Aspose.Grid.

Thanks you anyway.


#7

hi, is there some news for the second question ?

thanks.


#8

I found this problem. However, chart setting is complex so I haven’t fixed it yet. It will take another few days to make it. You will get the fix within one week. Thanks for your patience.


#9

ok, we will wait for that.

thank you