Free Support Forum - aspose.com

Spaces = Line Break?

Afternoon,

I am trying to use #$NBS like this:

txtNotes.Segments[0].Content = data.Replace("\n", “
”).Replace(" ", "#$NBS ");

But when the pdf is generated, everything after a $#NBS is on a new line, as if its treating them like line breaks.

I’ve tried the latest version 3.6.1.0 and have the same problem. Any help?

-Jeff

Dear Jeff,

We can’t reproduce this error. Can you please provide complete code that can reproduce this error?

I can’t provide my project as an example, and I don’t really have time to create a dummy project to reproduce it.

I don’t let my users put html into that field anymore, so for a temporary work around, it’s fine.

I can tell you the way my project is basically setup though.


I have a “Shell” xml document that I load up that contains 99% of what I need in the PDF. I think gather some information from the database, and one by one, use GetObjectByID to grab an instance of each text element I need to modify, and update its content accordingly.

In one case, I had html coming in, and the pdf didn’t like the non-breaking-spaces. Sometimes it picked them up, sometimes it didn’t. So I tried converting them to #$NBS but that didn’t work at all, each one became a linebreak.

I verified the xml looked fine, but I didn’t really have a lot of time to dwell on this. If I can in the future i’ll create a dummy project to show you.

Regards,
-Jeff