We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Spaces lost when saving to PNG image

Some spaces are not included in exported to PNG files.
We are using com.aspose:aspose-slides:18.9:jdk16 on Ubuntu Linux.
Where can I upload the PPTX file and the generated image?

@marc_aspose,

I have observed your comments. Can you please share source files and generated along with working sample code so that we may further investigate to help you out. Also you can attach your files with this forum.

Hi, this is de code snippet we use to write the image:

	final BufferedImage image = slide.getThumbnail(1.5f, 1.5f);
	ImageIO.write(image, "jpg", targetFile);

I have attached the PPTX and an example of generated image with missing spaces.

Archive.zip (4.7 MB)

@marc_aspose,

I have worked with source files shared by you using Aspose.Slides for Java 18.9 and unable to observe any issue. I have also shared my generated result with you for your kind reference. Can you please check attachment. Also please share complete environment details with us so that we may further investigate to help you out.Slide_6.jpeg (66.3 KB)

Hi Adnan,

Did you run your test on linux?
The problem does not appear on my Mac.

We are having the described problem on two different linux servers:

Server A:
Distributor ID: Debian
Description: Debian GNU/Linux 9.5 (stretch)
Release: 9.5
Codename: stretch
Java™ SE Runtime Environment (build 1.8.0_181-b13)
Java HotSpot™ 64-Bit Server VM (build 25.181-b13, mixed mode)

Server B:
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty
Java™ SE Runtime Environment (build 1.8.0_181-b13)
Java HotSpot™ 64-Bit Server VM (build 25.181-b13, mixed mode)

@marc_aspose,

I have observed your comments. A ticket with ID SLIDESJAVA-37377 has been added in our issue tracking system to resolve the issue. This thread has been associated with the ticket so that we share notification with you once issue will be fixed.

Hi, is there any news on this issue? My users are getting a bit frustrated with this…

@marc_aspose,

I like to share that the issue has just recently been added in our issue tracking system and is pending in issues queue at the moment. We request for your patience till the time the issue gets scheduled for investigation and resolution on its due turn.

The issues you have found earlier (filed as SLIDESJAVA-37377) have been fixed in this update.