Free Support Forum - aspose.com

Special character issue

Hi Gurus,

We are in the process of migrating Excel 2003 reports to Excel 2007 version with Aspose. It was found that one of the reports generated by Aspose failed to open in Excel 2007. The error message reads “Excel found unreadable content”. We then generated the same report in Excel 2003 with ExcelWriter, and narrowed down the problem to be some special character handling issue.

Attached please find the reports generated by Aspose (xlsm format) and ExcelWriter (xls format). You may find the trouble-making character in xls file. Please let us know if it is an Aspose issue or it’s a limitation of Excel 2007. What could we do to prevent it?

Looking forward to your response.

Thanks,
Michelle

Hi Michelle,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for considering Aspose.

We have found your mentioned issue after an initial test. We will look into your issue and get back to you soon.

Thank You & Best Regards,

Hi Michelle,

Thank you for considering Aspose.

Please try the attached latest version of Aspose.Cells. We have fixed your mentioned issue regarding special characters.

Thank You & Best Regards,

Hi Nausherwan,

Thanks for the quick fix. I am having some problem with testing the new library as I don’t know how to get this special character into my database. The Excel file I provided before was generated from the customer instance. This character was converted to empty space if I simply copy and paste it.

I am curious what you have changed to fix the issue. How did you get this mail-icon like character to show in your data (it was actually some kind of carriage return character). After the fix, what does it look like in the generated file? Can you provide some hint to test and also attach the generated xlsm file based on my testing data.

Thanks,
Michelle

Hi Michelle,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for considering Aspose.

Well, you may use your shared XLS file and convert it to XLSM file and see if all the special characters are converted fine. Please check it and let us know if the latest fix works fine for you.

Thank You & Best Regards,

The issues you have found earlier (filed as 10219) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.