We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Spell checking disabled in docx after export

Hi

We are using Aspose.Words .Net version 16.2.
After executing an export to a Word document, spell checking is disabled. We found a work around: after the export has been done and the document has been opened in Word, we go to Review menu -> Languages -> Set proofing language… In the pop-up, click on the “Set As Default” button. Then, spell checking highlights misspelled word.

Even if this work around exists, we would like the spell checking to be enabled when we open the document. How can we proceed?

Thank you.

@MathildeLORCoE

Please note that all text of the document is stored in Runs of text. Please iterate over the Run nodes of document and set the value of Run.Font.NoProofing property to false. Font.NoProofing property returns true when the formatted characters are not to be spell checked.

@tahir.manzoor
Thanks for your answer. We will test your solution.