We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SSRS 2008 report subscription attachement not detecting license

SSRS 2008 report subscription attachement does not seem to be detecting our license file. The standard export to PPT works fine but when I send a report subscription email with PPT as an attachment, the attachment shows the water mark indicating the license is not being recognized.

Is there something that needs to be configured for the SSRS report subscripions to recognize the license file when attaching a PPT file rendering?

Hi,


I have tried to understand the issue shared by you and have not been able to understand the second part of your query where you have mentioned, “but when I send a report subscription email with PPT as an attachment, the attachment shows the water mark indicating the license is not being recognized.”. Can you please elaborate this point.

Secondly, there is no hard and fast requirements for installing the Aspose.Slides for Reporting Services license. One only need to copy the license file to location where SQL Reporting Services instance is installed. Please visit this link for your kind reference.

Many Thanks,

Thank you for the reply. I understand that enabling the license is as simple as dropping the license file to the correct location on the server. We have successfully done that and exporting to PPT from the report toolbar works fine.

The issue is when receiving the PPT attachment as an email from SSRS subscriptions. I don't know how familiar you are with SQL Reporting Services but it has a feature when you go to the report management section that allows you to create scheduled subscriptions. The subscription allows you to stipulate many things such as the email receipients, when you want the report to run as well as setting the report parameters. Also you can set the email subject and body as well as whether to send the report as an attachment and, if so, you can specify the file format same as when you export from the report directly.

This is the feature that is not recognizing the license file. If I send a report subscription to a receipient and specify the report to be delivered as a PPT attachment, the report shows the non licensed version.

Hope this explains things.

Jonathan

Hi Jonathan,


I have observed the requirements shared by you. I have created an issue with ID SLIDESREP-33213 in our issue tracking system to further investigate the issue. I will update you further as soon as information will be shared by our development team in this regard.

Many Thanks,

Hi Jonathan,

Can you please try using Aspose.Slides for Reporting Services 4.11 on your end and share your feedback that if the issue is still incurring on your end or not.

Many Thanks,