We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SSRS Excel Data Only Export

Im still getting the 2 tabs, but the data from the second tablix is starting after 15 blank rows... Also the report header is still showing on the first tab.

(see attached)


Please try the latest installer instead: Aspose.Cells for Reporting Services v1.8.0.8 (MSI) and let us know your feedback.

Please post your report define file(*.rdl) here.

We will check it soon.

I tried the new install, and have the same issue.

The second tablix shows on a new tab, but the data starts on row 15, and the report header still shows on the first excel sheet.


Thanks for your feedback and sharing RDL file here.

We have logged it and we will look into your issue soon.

Thank you.


Please download and try the fixed version: Aspose.Cells
for Reporting Services v1.8.0.9 (MSI)

Let’s know your feedback.

The extra rows at the top of each sheet are now gone... but the report header still shows on the top of the first sheet.

How do I get rid of this when going to Excel data only?


We have checked your provided report define file (Time Summary.rdl).

There is no page header element in the Time Summary.rdl file. Do you want to export table report item data in body element, except Textbox1 item? If yes, please set Textbox1 to no output. If you do not set Textbox1 to no output, we will add new configuration to control data export.

Thank you.

I did set the Textbox1 to no output, and it still outputs in the excel file. I would like that all elements set to noOutput, do not output in Excel Data only (including any Tablix that is set to nooutput)

Additonally, I have another report that has a tablix that is hidden, and is set to allways output, but it doesnt ouput .... i guess since its hidden (I would like this one to output even know its hidden if its set to Allways Output


Could you provide us your input RDL and output Excel file by Aspose.Cells for RS component. Also provide us your expected Excel file. We will check it soon.

Thank you.


We have found this issue and fixed it.

Please download and try the fix: Aspose.Cells for Reporting Services v1.8.0.11

Still have two issues:

1. The report title no longer shows in the Excel file where it is set to NoOutput, but the Export in Excel starts on the second Row. (the first row is blank). It looks like it is still leaving space in the export where the texbox would have been. I would like the Data Export to start with the 1st row. (see the Time Summary.rdl in earlier post for the RDL)

2. I have a second report with two Tablix areas. The first one is for displaying for printing, and the second is for when there is a data export. (the first tablix is visible, but set to NoOutput, the second is hidden, but set to Always Output.) .. When I export to Excel data only, I get no data at all. (see the WebReferal.rdl attached in earlier post) .. this works as expected when I export to XML via native SSRS export.


We have fixed two issues.

Please download the fixed version: Aspose.Cells for Reporting Services v1.8.0.12 (MSI).

Ok.. looks like all my issues have been fixed in the latest build.

Is there a way to change the display in the export option from "Excel2007xlsx(Data Only)- Excel 2007 via Aspose.Cells" To something more user friendly.. Like Excel - Data Only? I would like this to be customizable via a configuration .. like

Excel (Data Only)


Please see if it is helpful.

Please reference to Customizing Rendering Extension Parameters in RSReportServer.Config at MSDN web site.

See the subsection.
Changing the Display Name

Please also see this additional information.

You can remove the unnecessary extensions from rsreportserver.config file found at C:\Program Files\Microsoft SQL Server\MSSQL.x\Reporting Services\ReportServer\rsreportserver.config

You will see there something like this

Just remove undesired extensions and you can rename them as I told you before.

Please see this document for your more help: Aspose.Cells for Reporting Services - Using DLL Only.

How do I get a quote on getting this version? is it possible to get it with source code?


Please refer following context to update your rsreportserver.config


Excel (Data Only)




I have a report that has groups, when I do an export to Excel Data only, I would only want the data, but the group headers are also exporting in the data. I tried setting the group headers to NoOutput, but they still show.

(i've attached the RDL)


Thanks for the RDL file,

Could you also attach your exported Excel file here. Also, attach your expected file here.

We will check it soon.

Thank you.

I added the two excel files… original, and proposed. I also highlighed the rows in the original I think that should be removed


Thanks for your files.

We have logged your issue in our database. We will look into it and provide you a fix or advise you asap.

This issue has been logged as SSRS-40019.