We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Stamping sometimes leads to errors

Using Aspose.Pdf.Kit to stamp existing PDFs I have some PDFs that er being displayed with errors and Acrobate Reader Warnings like


Font “FAAAAI+Arial-BoldMT” was not found…

I attached an example that contains 4 files:
  • An unstamped source
  • A stamped source that is correctly stamped
  • An unstamped source
  • A stamped source that is stamped with errors
Could you tell me how to resolve the issue?

Thanks
Uwe

Hi Uwe,

While using the FormattedText to stamp the PDF file, please try to specify embedded attribute as true. This will embed the required font in the PDF file, and hopefully resolve your issue.

However, if you still find the problem at your end then please share the code snippet with us, which you’re using to stamp the PDF file, so we would be able to test the issue at our end.

We’re sorry for the inconvenience.
Regards,

Thank you.


I am stamping a dynamically generated PDF file. I generated the PDF file directly from Aspose.Words.

Now I changed this to go through Aspose.Pdf and using the Pdf.TextInfo.IsFontEmbedded = true.

This succeeds. Hopefully the way through Aspose.Pdf can be omitted someday in the future.

Hi Uwe,

You might consider logging this request in Aspose.Words forums, so that they’ll be able to help you out.
http://www.aspose.com/community/forums/aspose.words-product-family/75/showforum.aspx

Regards,