Free Support Forum - aspose.com

Subreport Cells are not exported

Upgraded to SSRS Cells 1.1.1.0

Subreport Cells are not exported to Excel 2007

I thought this was a fixed function

Note the subreport is in a group footer

Hi,

Could you post your RDL file here, we will check it soon.

Thank you.

Here is RDL of Main and Subreports

Hi,

Thanks for providing RDL files, We will check your issue soon.

Thank you.

Hi jtpurvis,

Please try this fix.

Hi jtpurvis,

Please try new fixed.

This fixed do not support the background picture in pageHeader. Please use image in pageHeader.

If the problem is persists ,please feedback.

Patch fixed the subreport rendering issue.

Next problem is lic file is no longer recognized and evaluation warning is present

Additional function that would be great if included is to pass the spreadsheet grouping functionality to Excel. Built-in renderer exports the group by function to the speadsheet Aspose export does not??

Thanks for the patch it is a good start at resolving our problems

Hi,

Could you try the following user actions:

----------------------------------User Actions---------------------------------

  • Check aspose.cells.reportingservices.dll version if it is same fix (Or otherwise you have uninstall the older and install the newer fix.) in the SSRS folder(C:\Program Files\Microsoft SQL Server\MSSQL.2\Reporting Services\ReportServer\bin)
  • Rename the licence filename to Aspose.Cells.Reporting.Services.lic . Please note capitalization.
  • Copy it to the licence folder($[installation folder]/Licence/).

--------------------------------------------------------------------------------

Thank you.

hi,jtpurvis

please try the new fix.
In this version, Excel group is used to process the hidden group rows.

Thank you.

Update fixes group function, Thanks

I now get the attached error in Excel 2007, if I click OK the file seems to import correctly.

Not sure what the impact of the error is, if any, but needs to be resolved.

Hi jtpurvis,

Please try this fix.

-------------------------User Actions---------------------------

  • Please uninstallation old version.
  • Open excel , click Tools-->Add-Ins menu.
  • Cancel Aspose.Cells.ReportingServices.Client checkbox.
  • Click OK buttom.
  • Please installation this fix.

-----------------------------------------------------------------

If the problem persists ,please feedback.