Free Support Forum - aspose.com

SVG output differs from Visio map content


#1

Hi


We are currently testing the Save As SVG functionality and are experiencing some issues where the SVG output does not match that of the source vsdm file. I’ve attached the source Visio file, the SVG output produced from Visio (svg_1.svg) and the SVG output from the Aspose Diagram software (SK sample.svg). Please could you investigate? I can provide further information if needed.
- The map title is not correctly indented
- The gradient in the title bar is not displayed correctly
- The up button in the bottom left corner does not display the correct image
- The version text at the bottom of the screen is over-written with additional text
- The email button in the bottom right corner is not shaded correctly

We will be testing extensively over the coming weeks so I’ll post any further issues as we find them.

Thanks,
Andrew

#2

Hi Andrew,


Thank you for sending a Visio drawing and SVG file. We have tested your source drawing against the latest version 17.3.1.0 of Aspose.Diagram for .NET API and managed to replicate issues as you narrated. We have logged tickets as below:

DIAGRAMNET-51175: The title text is displaced on converting a VSDM to SVG
DIAGRAMNET-51176: The gradient title bar is changed on converting a VSDM to SVG
DIAGRAMNET-51177: The arrow button is not being displayed correctly on converting a VSDM to SVG
DIAGRAMNET-51178: A duplicated text line is over-written while converting a VSDM to SVG
DIAGRAMNET-51179: Incorrect shading over an email button on converting a VSDM to SVG

Your post has also been linked to these tickets. We shall keep you informed regarding any available updates. We are sorry for the inconvenience caused.


#3

Hi Andrew,


Thank you for being patient. Our product team has resolved the ticket ID DIAGRAMNET-51177. If there is no issue in the quality assurance phase, then this would be included in the next version of Aspose.Diagram API. We shall let you know once the new release is published with its fix.


#4

Hi Andrew,


Thank you for being patient. In reference to the ticket IDs DIAGRAMNET-51177 and DIAGRAMNET-51178, please download and try the latest Hotfix version: Aspose.Diagram for .NET 17.3.2.0. Please also let us know how that goes on your side.


#5
Hi Imran

I've tested the hotfix with the following results.

DIAGRAMNET-51177: This is much better and I can see the arrow correctly; however for the blue colouring around the arrow, the gradient is not displaying as on the original Visio diagram.

DIAGRAMNET-51178: This has been fixed correctly

Thanks,
Andrew

#6

Hi Andrew,


Thank you for the feedback. We have passed this information to our product team against the ticket ID DIAGRAMNET-51177. We shall let you know once an update is available from our product team.


#7

The issues you have found earlier (filed as DIAGRAMNET-51177;DIAGRAMNET-51178) have been fixed in Aspose.Diagram for .NET 17.4.0.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

#8

I have tested the issues addressed as part of the 17.4.0 release and have listed the results below.


issue 51177 = fixed (although the shading is not correct - I believe this is being fixed as part of a separate issue)
issue 51178 = fixed

Thanks,
Andrew

#9

Hi Andrew,


Thank you for the confirmation. In reference to the ticket ID DIAGRAMNET-51177, the incorrect shading problem is the same as we have logged under ticket ID DIAGRAMNET-51179. We have passed this information to our product team against the ticket ID DIAGRAMNET-51179. We shall let you know once the significant progress has been made in this regard. We are sorry for the inconvenience caused.


#10

@andrew.ridgeley,

The linked ticket ID DIAGRAMNET-51175 has been resolved and will be included in next version 18.2 of Aspose.Diagram for .NET API. We will notify you once the next version is published.


#11

@andrew.ridgeley,

In reference to the linked ticket ID DIAGRAMNET-51175, please download and try the Hotfix version: Aspose.Diagram for .NET 18.1.1.


#12

@andrew.ridgeley,

The linked ticket ID DIAGRAMNET-51175 has been resolved and included in the full version 18.2 Aspose.Diagram for .NET API. Please download and try the latest version 18.2 of Aspose.Diagram for .NET API.


#13

The issues you have found earlier (filed as DIAGRAMNET-51176) have been fixed in Aspose.Diagram for .NET 19.4.


#14

The issues you have found earlier (filed as DIAGRAMNET-51179) have been fixed in Aspose.Diagram for .NET 19.5.