Free Support Forum - aspose.com

Table border doesn't render correctly when clone multiple rows


#1

Hi All,

I am trying to clone multiple table rows from a table in a pptx file using C#. I’m using the code as described below:

     // Access the slide
                ISlide sld = presentation.Slides[0];

                // Initialize table
                ITable table = (ITable)sld.Shapes.FirstOrDefault(s => s is ITable);
                
                table.Rows.AddClone(table.Rows[2], false);
                table.Rows.AddClone(table.Rows[3], false);

                // Write the PPTX to Disk
                presentation.Save(dataDir + "UpdateTable_out" + string.Format("{0:yyyyMMddhhmmss}", DateTime.Now) + ".pptx", SaveFormat.Pptx);

The output ppt contains the added cloned row at the bottom of the table but the border of the second row doesn’t get render correctly. It remains visible across the length of first cell only. Check the issue as illustrated in image below.

HalfBorder_Issue.png (8.8 KB)

Kindly let me know how to resolve this issue.

Thanks,
Jitu


#2

@JituS,

I have observed the issue shared by you and request you to please share the source presentation and generated output reproducing the issue on your end.


#3

@mudassir.fayyaz

Sharing the source presentation in zip file UpdateExistingTable.zip (26.6 KB) and generated output UpdateTable_out20190517052901.zip (27.6 KB)


#4

@JituS,

I have worked with the sample presentation shared by you and have been able to observe the issue specified. An issue with ID SLIDESNET-41129 has been created in our issue tracking system to investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.