Free Support Forum - aspose.com

Table borders not rendered correctly in PDF

Hello


When rendering a powerpoint (pptx) file to PDF with aspose.slides.
The thickness of the borders isn’t rendered consistent.
We’ve tried editing the the borders manually, but without a good result.

We’re using JDK1.7, and Aspose Slides 16.1.0 (Total.license)
This is our code :
Presentation doc = new Presentation(filepath.pptx);
PdfOptions saveOptions = new PdfOptions();
doc.save(outFilePath.toString(), SaveFormat.Pdf, saveOptions);
I’ve included our sourcefile and the generated pdf.
(The right side of the table has different border thicknesses)
Would you be kind to look into this issue?
Thank you in advance !
Samnang

Hi Samnang,


Thank you for posting.

I have observed your comments and worked with the presentation file shared by you. I have been able to reproduce the issue. A ticket with ID SLIDESJAVA-35259 has been logged in our issue tracking system to further investigate and resolve the issue.This thread has been linked with the issue so that you may be notified automatically as soon as the issue will be resolved.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESJAVA-35259) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Thanks!


I’ve just tested it, and it renders perfectly!

Hi Samnang,


Thank you for your valuable feedback.

We are glad to know that your issue is resolved and things have started working on your end.

Please feel free to contact us if we could be of any help to you.

Best Regards,

Hi, how are you?
I’m suffering with this issue in Aspose.Slides for .Net.

When saving file in Pdf format, the table borders get tick (while in PPT I don’t have this problem).
Could you help me, please?

Presentation.DocumentProperties.Title = Path.GetFileNameWithoutExtension(name);
var pptOutputPath = Path.Combine(path, name);                
Presentation.Save(pptOutputPath, Aspose.Slides.Export.SaveFormat.Pptx);


Aspose.Slides.Export.PdfOptions options = new Aspose.Slides.Export.PdfOptions
{
	Compliance = Aspose.Slides.Export.PdfCompliance.Pdf15,
	EmbedFullFonts = true                    
};

var pdfOutputPath = pptOutputPath.Replace(".pptx", ".pdf");
Presentation.Save(pdfOutputPath, Aspose.Slides.Export.SaveFormat.Pdf, options);

@ruy.almeida.bnpp

I request you to please try using latest Aspose.Slides for .NET 20.8 and in case the issue is reproduced, please share the source file and generated output reproducing the issue on your end.

Ok. I’ll try this version.
Thanks

Even after updating Aspose.slides from version 20.6 to 20.8 it didn’t work properly. Unfortunately I’m not allowed to share neither the source file or the output file. I can share only the versions of frameworks/libraries I’m using.

I discovered that setting this property (https://apireference.aspose.com/slides/net/aspose.slides/itable/properties/firstcol) to “false” solves my problem.

Thanks for your attention.

@ruy.almeida.bnpp

It’s good to know things are fine on your end with the help of API reference guide.

1 Like