We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Template setup

To export a list item to pdf, I need to setup template storage and template name.

Template storage is easy, but I have been unable to get an entry to template name.

The support article on this makes no sense and is poorly written, where do these xml files come from? Where are they uploaded?

I just want convert my list item to PDF format.

Hi John,

Thank you for considering Aspose.Pdf.

Well, you can refer to the following documentation for detailed steps on how to create an XML, upload it to PDF template and then Export it to PDF.

In case you have any confusion, please do let us know.

Thank You & Best Regards,

Used infopath to export source files, used the xml generated to give me a template.

But now the export button does nothing, I dont know if it should be putting a pdf somewhere. An error prompt would be nice.

The xml suggested ‘test.xml’ will also give no error if used.

I have also tried to use Tasks Form Template (for Item).xml that included in a zip file that was suggested in a setup guide.

Without any errors from this program, it will not be possible to learn why operation is failing or what the problem is with the xml file.

Hi,

Please share the details regarding your system environment with us like OS, SharePoint version, Browser etc. This will help us to create the same environment as you have and regenerate the issue.

Sorry for the inconvenience,

Internet explorer 8. Sharepoint 2010 RTM 14.0.6029.1000

Running windows server 2008.

Hi John,

Thank you for the details.

I have shared all the details regarding your issue with our development team to further investigate this issue. I have created an issue in our issue tracking system with issue id: PDFSHP-32601 . You will be notified via this forum post regarding any update against your issue.

Sorry for the inconvenience,

Hi John,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Please share the template xml files you have tried at your end and also the screenshot of the screen with disabled Export button. This will help us in understanding the cause of the issue and figure it out soon.

Thank You & Best Regards,

As I mentioned previously -

I used 'test.xml' from the setup guide.

I also tried to use Tasks Form Template (for Item).xml that included in a zip file that was suggested in a setup guide.

The export button looks normal, it's just that it has no function when pushed.

Hi John,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Please perform the following steps and share the output with us.

1. Clear folder c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\

2. Execute the Export process again to reproduce the issue.

3. Zip the logs folder i.e. c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\

4. Share the zipped folder with us via this forum thread.

This will help us identify the issue soon.

Thank You & Best Regards,

Please remove this case, I have used another solution now.