We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Text of HyperLinks is lost when saving workbook as ODS

Hello,

We have a file in ODS format, containing some hyperlinks.
Once saved as ODS by Aspose.Cells the hyperlinks have no text anymore (links are still there according to the mouse pointer when hovering the cells).
The same problem occurs when saving as PDF (links with no text are not visible) or HTML (links with no text are visible only due to the fact that they are underlined in blue).

Aspose.Cells version: 20.4

Please, find in the attached file the input/output files and the simple code that was used.
files.zip (32.7 KB)

Regards.

@julien.mevel.isilog,

Thanks for the sample code, sample files and details.

After an initial test, I am able to reproduce the issue as you mentioned by using your sample code and sample ODS file. I found text of hyperlinks is lost when re-saving an ODS file or rendering to PDF/HTML file format. I have logged a ticket with an id “CELLSNET-47327” for your issue. We will look into it soon.

Once we have an update on it, we will let you know.

@julien.mevel.isilog,

We have fixed the issue of losing text of the hyperlinks in the output file(s), we will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes. But there is another issue that a cell with hyperlink could be rich formatted in Open office which is forbidden (not allowed) in MS Excel. We could not fix it soon, so you have to live with the upcoming fix.

@julien.mevel.isilog,

Please try our latest version/fix: Aspose.Cells for .NET v20.4.5 (attached)

Your issue should be fixed in it.

Let us know your feedback.
Aspose.Cells20.4.5 For .Net2_AuthenticodeSigned.Zip (5.3 MB)
Aspose.Cells20.4.5 For .Net4.0.Zip (5.4 MB)

The issues you have found earlier (filed as CELLSNET-47327) have been fixed in Aspose.Cells for .NET v20.5. This message was posted using Bugs notification tool by Amjad_Sahi