TextFragmentAbsorber with AWS


#1

Hello Aspose support…

I was prototyping a Lambda function for one of our projects to add hyperlinks inside briefs. The function works great when I run it using a test project on my PC. However, when I run it on AWS Lambda I am getting errors inside an Aspose call. Specifically, the problem is with the TextFragmentAbsorber. I am able to create the absorber fine, but when I try to apply it to my document it blows up.

I am using version 18.7.0 of the Aspose.PDF library (published two days ago), but I have tried this with every version back to 18.4.0.
My function uses the AWS Lambda function solution template with the S3 Event blueprint.

I have attached my function source file and project file. I also attached a screenshot of a CloudWatch log of the execution of the function with a stacktrace. The problem occurs on line 122 of Function.cs. Finally, I have attached a sample pdf file that I am using to test the function.

I added several debugging messages to my code so that it could be followed in the CloudWatch log.

My questions to Aspose are:

  1. Are they aware of this problem?
  2. Is this a problem they intend to fix?
  3. What timeframe for a resolution?
  4. Is there a workaround?TestHyperlink.pdf (88.7 KB)
    CWLogAsposeError.PNG (23.0 KB)
    SampleFiles.zip (130.6 KB)

#2

@ILSTech

Thank you for contacting support.

We used to have some compatibility issues of Aspose.PDF for .NET with Amazon Web Services but we had no information about problem with TextFragmentAbsorber in AWS. For the sake of further investigation, we have logged this problem as PDFNET-45063 in our issue tracking system. We will further look into the details of this problem.

We are afraid that a workaround or ETA for this issue may not be available until the ticket is investigated. Moreover, it has been logged under free support model, so the resolution can take several months. We appreciate your patience and comprehension in this regard.

We are sorry for the inconvenience.