We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Thai language is not supported while converting pptx stream to pdf

Hi Team,
I am having issues in converting the PPTX stream to pdf files. thai language is not supported.


Aspose.Slides version- and 14.8. nothing seems to be helping my case.

Please refer the piece of code below,

public Stream Convert(Stream presentationStream)
var presentation = new Presentation(presentationStream);
var saveOptions = CreateSaveOptions();
var pdfStream = new MemoryStream();
presentation.Save(pdfStream, SaveFormat.Pdf, saveOptions);
pdfStream.Seek(0, SeekOrigin.Begin);
return pdfStream;
catch (Exception ex)
return null;
presentationStream.Seek(0, SeekOrigin.Begin);


I have observed your comments. Can you please share source presentation so that we may further investigate to help you out. I also suggest you to please try to use Aspose.Slides latest version 17.8 on your end and if there is still an issue than please share source presentation.

Thai issues.zip (548.4 KB)

Please find the attachment.


I have worked using Aspose.Slides for .NET 17.8 on my end and have not been able to reproduce the issue. For your kind reference, generated PDF is also attached.

Export_Thai.pptx.pdf (314.1 KB)

Thanks for the update. Can you pleased let me know if 15.8 works for you? Just wanted to be sure that my way of conversion is right.

Also, could you please let us know if 17.x is backward compatible. if i use this version of aspose.slides in my project will it break the functionalities of 15.3 or older version? I am checking this at my end, butit would be great if you can let me know the same.


I have tested the presentation using Aspose.Slides for .NET 15.8 as well on my end and have successfully generated the PDF without any issue. For your kind reference, I have attached the PDF file as well. It may be a case of missing font on your end as API has no issue in generating PDF.

Export_Thai.pdf (316.6 KB)

Its 15.3 not 15.8. Thanks!! I really dont know what is missing in the code above. By missing font what do you mean?


We have tested the presentation using Aspose.Slides for .NET 15.8 based on your following request.

Secondly, I have tested using Aspose.Slides for .NET 15.3 as well and results are good. I have observed that when using following sample code using Aspose.Slides for .NET 17.8, five fonts have been used in your presentation.

var fonts= PresentationDoc.FontsManager.GetFonts();

You need to make sure if these fonts are installed on your end or you can copy the shared fonts on your disk and load them externally in your application before loading the presentation. I hope the shared information will be helpful.

Thank you once again. But if fonts are the issue then how is it rendering properly in my PPTs? I am worreid that we are missing something here.


I don’t think that there is any thing missing as the same versions that you reported failing to work with your presentations on your end have no issue on my machine. Therefore, I have suggested you to please ensure the used fonts availability as mentioned in my previous post and verify the results. If there is still an issue then please provide the Visual Studio sample project and Operating System details used on your end.

Hi Team,
This part of our project converting the PPTX to PDF uses Aspose 14.8. I tried to check the same with 14.8 and 17.8. 17.8 seems to fix the issue and 14.8 does not. So is this an issue with this specific version of aspose? Also let me know if I try to use 17.8 now in my project will it break the old implementations?


It’s good to know that latest version is not throwing any more issue on your end. As far as your comments related to any breaking changes are concerned, I like to mention that the latest release is far more stable and much richer in terms of features as compared to old version you have referred. Also, there is a gap of 3 years between Aspose.Slides for .NET 14.8 to Aspose.Slides for .NET 17.8 and there have been many improvements in API. The best approach would be to use latest version on your end and check if there is any issue. Otherwise, it is not possible to tell any thing about breaking changes.

Moreover, I also suggest you to visit the month wise Release Notes that you can refer on your end to observe any new additions, changes or removals from API.

I have attached my sample project using 15.6 Aspose.Slides. This returns a file that errors out while opening. Could you please have a look?

We cant use the updated version as many of our existing methods are obsolete.

I have attached my sample project using 15.6 Aspose.Slides. This returns a file that errors out while opening. Could you please have a look?

We cant use the updated version as many of our existing methods are obsolete.ThaiExport.zip (293.1 KB)

Removed the reference to 15.6 since the file size is too big. Please add reference, correct the file path and try to run the application.


I have also verified your presentation using Aspose.Slides for .NET 15.6 on my end and have successfully generated PDF. I also like to mention that even if there arise an issue with when using some old API version but that is no more reproducible in latest API then we suggest customers to please use the latest version. If the latest version also reproduce the issue then we add that in our issue tracking system for resolution. I suggest you to please try some other machine for exporting PDF as there seems no issue with API when exporting to PDF with all product versions requested by you.

testQV.pdf (631.2 KB)

Can you try converting it into hindi once ?


I am sorry, I didn’t get your question right. Is there any thing else you would like me to offer you.

@mudassir.fayyaz actually we require support for multiple languages and the issue is coming while converting the presentation to thai , hindi and simplified chinese .

Here is the Presentation in Hindi . Try converting it to PDF once