Free Support Forum - aspose.com

The method or operation is not implemented

We have installed the Aspose BarCode for Reporting services on a computer using the instructions on your website and it is giving the message "The method or operation is not implementedThe method or operation is not implemented" When you try to drag the Aspose BarCode to the report from the toolbox.

We are using 4.8 and have also tried your latest version with the same results. If I copy a barcode from an existing report and paste it to the new reprt I am able to make changes to the barcode without any issues with the Aspose software.

This is a Windows 7 Professional x64 system.

Hi Bill,


Thank you for your inquiry. While using the latest version of Aspose.BarCode for SSRS v5.3.0, I’m unable to reproduce this error message when I tried to drag the barcode control to the report from the toolbox. Could you please describe exact steps and environment details? You can also take help of snap shots etc. This will help us to reproduce the problem on our side. We’re sorry for your inconvenience.

Microsoft Visual Studio 2005
Version 8.0.50727.4039 (QFE.050727-4000)
Microsoft .NET Framework
Version 2.0.50727 SP2

Installed Edition: Professional

Microsoft Visual Basic 2005 77626-009-0000007-41075
Microsoft Visual Basic 2005

Microsoft Visual C# 2005 77626-009-0000007-41075
Microsoft Visual C# 2005

Microsoft Visual C++ 2005 77626-009-0000007-41075
Microsoft Visual C++ 2005

Microsoft Visual J# 2005 77626-009-0000007-41075
Microsoft Visual J# 2005

Microsoft Visual Studio 2005 Tools for Applications 77626-009-0000007-41075
Microsoft Visual Studio 2005 Tools for Applications

Microsoft Visual Web Developer 2005 77626-009-0000007-41075
Microsoft Visual Web Developer 2005

Microsoft Web Application Projects 2005 77626-009-0000007-41075
Microsoft Web Application Projects 2005
Version 8.0.50727.762

Crystal Reports AAC60-G0CSA4B-V7000AY
Crystal Reports for Visual Studio 2005

Microsoft Visual Studio 2005 Professional Edition - ENU Service Pack 1 (KB926601)

SQL Server Analysis Services
Microsoft SQL Server Analysis Services Designer
Version 9.00.1399.00

SQL Server Integration Services
Microsoft SQL Server Integration Services Designer
Version 9.00.1399.00

SQL Server Reporting Services
Microsoft SQL Server Reporting Services Designers
Version 9.00.1399.00

SQL Prompt 5
Version 8.0.50727.4039 (QFE.050727-4000)
Microsoft .NET Framework
Version 2.0.50727 SP2

Right click SSRS Reports -> Add -> New item ->Report

Add a table from the toolbox, select the middle detail column, then drag Aspose Barcode onto it.

Last year when one of the developers installed the product they had the same problem but they cannot remember what was done to solve it. The computer has 8 gig of RAM, Intel Core i7 - 2600 CPU @ 3.40 GHz running Windows 7 professional 64 bit with SP1 and has all Windows updates current.

Hi Bill,


Thank you for your details. It is to update you that I’m unable to reproduce the problem with Windows XP VM. I’m preparing environment of Windows 7 (64 bits) to test this scenario. I’ll update you at the start of next week. I’ve also attached a snapshot for your reference.

I am still having this issue and it is getting hard to work around. Currently I am copying existing bar codes but that only works if it is the same cell size/configuration between the two reports.

Hi Bill,


Thank you for your inquiry and sorry for the delay. I’ve prepared a VM with the above environment like Windows 7 professional 64bits and SQL Server 2005 64bits but still unable to reproduce the problem on my end. In your case, can you please remove barcode element from the tool box and then include it again? Also please make sure that you have dropped Aspose.BarCode.ReportingServices.dll from SSRS2005 folder to the appropriate location as described here http://www.aspose.com/docs/display/barcodereportingservices/Visual+Studio+Configuration

In case, It does not help you then please share a sample project which reproduces the issue on your side. We will investigate it further to reproduce the problem.

This is an installation or configuration issue with the computer in question. When another developer opens the project they are able to drag the bar code on without an issue. the item has been added to the toolbox again and it is still the same issue. I have also dropped the dll in the correct location as described above.


This can only be reproduced on this one machine. Our lead developer said they had this same issue when the software was first installed after purchase about a year ago but they were able to resolve it. They no longer remember what fixed the issue but it was a configuration issue.

Hi Bill,


Thanks for these details. In this case, I will suggest you to uninstall Aspose.BarCode for SSRS component and then reinstall. If you observe the error message during this process then please share it here in this thread. We will take a closer look and guide you accordingly. Second, you can also install Aspose.BarCode for SSRS manually.
http://www.aspose.com/docs/display/barcodereportingservices/Install+Manually

I hope this will help you.