Free Support Forum - aspose.com

Thickness of rule not rendered accurately with Slide.getThumbnail()

Hello,



I am trying to render an slide from a ppt file, which I have attached to this post. The ppt file has a horizontal rule on many slides. This rule is thick on the left end, and the thickness diminishes halfway through the rule.



When I attempt to get a thumbnail of these slides, the rule is not rendered accurately. The thickness diminishes too soon in the image generated by Slide.getThumbnail(). I have attached an example image from the first slide in the attached ppt.



Here are some other details:

Aspose jar: aspose-slides-2.3.0.jar

Metafiles jar: aspose-metafiles-1.6.1.jar

Java version: 1.6.0_21-b06

Dear James,

I have worked with the presentation file shared by you and have been successfully able to generate the slide thumbnail with no problem. For your kind reference, I have attached the generated slide thumbnail as well. I am using following jar files for thumbnail generation.

  • aspose.slides_2.3.0_20100710.jar
  • aspose.slides_2.3.0_20100710.jar
  • jai_codec-1.1.3-alpha.jar
  • jai_imageio-1.1.jar
  • jai-core-1.1.3-alpha.jar

Thanks and Regards,

Mudassir,



Thank you for your quick response.



I looked at the image you posted, and I noticed that it has the same problem as the one that I posted. I don’t think I explained it very well in my original post. I am not concerned about the problems rendering the fonts. The problem is with the line below the title of the slide.



I have attached an image to illustrate the problem to this post… it contains two images of the first slide. The one on the top is a screenshot from powerpoint. The one on the bottom is the screenshot that you provided. On the screenshot on the bottom, I drew a circle around the problem so you can see which line I am referring to.



Thanks!

Dear James,

In light of your explanation, I have been able to identify the issue and it seems to be an inconsistency in Aspose.Slides for Java. An issue with ID 19429 has been created in our issue tracking system to further investigate and resolve the issue.This thread has also been linked with the issue, so that you may be automatically notified, once the issue is resolved.

We are sorry for your inconvenience,

Thank you Mudassir :slight_smile: