We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Thumbnail Generated with Aspose.Slides Looks Different for a Specific Slide

Hello,

We’re using aspose to generate slide thumbnails. It mostly works, but for this one slide the thumbnail is completely broken : Slide 3 of this file

Here is the code we use to generate the thumbnails through python :
slideToMerge = presentationToMerge.getSlides().get_Item(0)
image = slideToMerge.getThumbnail(2.0, 2.0);

How the slide should look like : https://drive.google.com/file/d/13AaVn4UpMlMpmKd1ICEQmiaWLnfhopCN/view?usp=sharing
How it looks like : https://drive.google.com/file/d/1ETQe3dFOVD8ZO1R6loMjioisb0FdUE0W/view?usp=sharing

Can you please check ?
Thanks!

@alb1,
Thank you for contacting support.

Please note that your expected result is incorrect. Unfortunately, I was unable to reproduce the problem with generating thumbnails for the presentation using Aspose.Slides 22.2 (Java and Python).

Please test your result using the latest version of Aspose.Slides if it is possible. If the issue persists, please share the following information about your environment:

  • OS version
  • JDK version
  • Aspose.Slides version

Hi,

Just tried with 22.2 and still the same thing.
zoom.jpeg (29.1 KB)

We’re running on this docker image : https://hub.docker.com/r/rappdw/docker-java-python on an Ubuntu 18.04.5 LTS machine

Thanks !

@alb1,
Thank you for the additional data. I’ve logged the issue with ID SLIDESJAVA-38733 in our issue tracking system. Our development team will investigate this case. We will inform you of any progress.

@alb1,
Our development team investigated the issue and was unable to reproduce the problem. We tried different versions of docker-java-python and Aspose.Slides, but everything works fine.

Could you please share a sample project to reproduce this issue?

Hi,

What kind of granularity do you need for the project share ?
Can you share with me the thumbnail you’re getting ?

Thanks !

@alb1,
We need the simplest project that can reproduce the problem you described.

Our result looks like this: slide_3_out.jpg (122.8 KB)