We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Transparency not working in pdf

Hi,

I have an issue when I save a chart with transparent color in pdf.

when I save in excell, chart is corect but in pdf the transparent color are white (see jpg)

I set transparency with following code

chart.NSeries[li].Area.Transparency = .5;

Hi,

Thanks for your posting and using Aspose.Cells.

Please download and use the latest version: Aspose.Cells
for .NET v8.2.0.2
and see if it resolves your issue.

Please note, you will have to save your pdf in PNG format to support transparency.

We have tested transparency with the following code and it generated the correct pdf. I have attached the source excel file and output pdf file for your reference.

If your issue still persists, then please provide us your source file and sample code replicating this issue with the latest version. We will look into it and update you asap.

C#


string filePath = @“F:\Shak-Data-RW\Downloads\source.xlsx”;


Workbook workbook = new Workbook(filePath);


PdfSaveOptions options = new PdfSaveOptions();

options.ImageType = ImageFormat.Png;


workbook.Save(filePath + “.out.pdf”, options);



It's work when I set

options.ImageType = ImageFormat.Png;

unfortunatly the quality is not good when I set this option.

there is an extra line not transparent in each area, see jpg

Hi Guillaume,


Thank you for writing back.

Could you please confirm that you have generated the PDF using the latest version (link shared in our previous response)? We have recently improved the rendering engine so we believe that you will not face the image quality problem with latest release. In case the problem persists, we need to review your complete source code as well as the template spreadsheet to properly investigate the presented scenario.

In case you are concerned about the privacy of your data, please replace any sensitive information with dummy data in your spreadsheet before sharing it on the public forum. Moreover, we can always mark the thread private so that no one but you & Aspose team members could have access to its contents/attachments.

Unfortunatly not with the latest version.

we have actualy no time to go through your latest change with DataModel before

Hi Guillaume,


Please give a try to the latest version using the simplest code of lines shared earlier here. If you get the correct results with expected quality that means the problem is in your current version of the API. In that case we can only suggest you to upgrade the API. Moreover, if the presented scenario is established to be a bug/issue in the API, we can only provide the fix with latest release. Therefore you have to upgrade anyway.

Please feel free to write back in case you need our further assistance.