We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Truncating commas

I'm having an issue where am reading in a file and then resaving it to an archive location. The file is CSV and it appears to be removing commas at the end.

BNYDCPE,08/15/2013,XB2NYGN,,Healy,,B11,401.80,,,,,,,BNYDCPE,08/15/2013,XB2NYGN,,Healy,,B11,401.80,,,,,,,

Becomes

DCPE,08/15/2013,XB2NYGN,,Healy,,B11,401.80,,,,,,,DCPE,08/15/2013,XB2NYGN,,Healy,,B11,401.80

Is there a setting that will prevent this? Just fyi, I am opening the file in notepad, not excel, so that's not what is causing the truncation.

LoadFormat loadFormat = LoadFormat.CSV;
SaveFormat saveFormat = SaveFormat.CSV;

Aspose.Cells.LoadOptions loadOptions = new Aspose.Cells.LoadOptions(loadFormat);

// Open the workbook and save it in the session
// Create the workbook
var workbook = new Workbook(fileName.ToString(), loadOptions);
workbook.Settings.ConvertNumericData = false;

Cells cells = workbook.Worksheets[0].Cells;


//workbook.Save(stream, saveFormat);

workbook.Save("c:\\bnym\\test.csv");

Thanks

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We were able to observe this issue using your sample code and source csv text. The commas at the end of line are truncated. We have logged this issue in our database. We will look into it and resolve this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-41917.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have looked into this issue and found that MS-Excel works same as Aspose.Cells. So it is not a bug of Aspose.Cells.

So there’s no way around it then?

Hi,

Thanks for your posting and using Aspose.Cells.

We are afraid, there is no other workaround to resolve this issue.