Free Support Forum - aspose.com

Trying to upgrade to new version of 3.6.3.1 from 2.3.1.0

error CS1577: Assembly generation failed -- Referenced assembly 'Aspose.Network' does not have a strong name

Hi,

I am trying to upgrade to latest version of aspose.network. I was having 2.3.1.0 and we got the new license file for the upgrade. When i include the ddl in out project, it gives me with above error message. But if i include the previous version of the aspose 2.3.1.0, it complies with out any problem. Will my license file have problem or am i doing some thing wrong.

The way i upgarded is, downloaded the version from http://www.aspose.com/Community/Files/54/aspose.network/category1102.aspx full installer version. Installed on my local and took the dll , XML and lic file and tried over writting on the one which has 2.3.1.0.

Tired re-attaching the dll, but still i have problem. Can some one shows light on this please.

Thanks

Malar

Hello,

It looks like we have some problem in the dll. We will get it fixed ASAP.

From 2.3.1 to 3.6, there are some breaking feature ugrades. They are not fully compatible. Could you please send me your code about how you are using the Aspose.Network 2.3.1? Our engineer will provide more guides on how to migrate the code to the latest version of Aspose.Network.

Best wishes,

Hi,

Here is code snippet which we are using :

Aspose.Network.Mail.Attachment attachment;

Aspose.Network.License license = new Aspose.Network.License();

license.SetLicense("Aspose.Network.lic");

Aspose.Network.Mail.MailMessage mailitem = new Aspose.Network.Mail.MailMessage();

string sSmtpServer = "localhost";

string fromAddress = fromAddress ;

string sUploadPath = sUploadPath ;

mailitem.Subject = sSubject;

attachment = new Aspose.Network.Mail.Attachment(sloc);

mailitem.AddAttachment(attachment);

mailitem.Save(sUploadPath + sEmailFileName);

Aspose.Network.Mail.SmtpClient client = new SmtpClient("sSmtpServer");

client.AuthenticationMethod = SmtpAuthentication.None;

client.Send(mailitem);

Hope this will help you.

Hello,

Please try this dll

http://www.aspose.com/Community/Files/54/aspose.network/entry102941.aspx

Thanks,

Hi

I tried with the ddl which is available on the location. But no luck. So i went one level down 3.6.3.0. Guess what, it compiled with no error. I am not sure what is upgraded in 3.6.1.0

Thanks for investigation