We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

TTD format- output has special characters

Hi. I’m noticing the appearance of extraneous characters in my TTD output. They can only be seen when using a hex editor, but they cause problems with existing data import processes.

When using Aspose.Cells for TTD format output, the DLL dated 17/12/2007, my output appears as text with tabs in the appropriate places as shown in the attached picture 20080923.jpg

When using the DLL dated 27/06/2008, the output appears with extra characters at the start and some sort of spacing character in between each ASCII character, shown in the attached picture 20081020.jpg. These are littered throughout the file.

Can someone explain to me why these characters are now appearing and how I can eliminate them? I am hoping there is simply a new configuration option I need to set before saving a TTD format file.




Hi,

After checking all overload Workbook.Save method, we have find some methods do not use System.Text.Encoding.Default when you do not specify the encoding type. We fix this issue and post a fix soon.

And please set the encoding type with the method Workbook.Save(string fileName, char separator, System.Text.Encoding encoding) and Workbook.Save(stream stream, char separator, System.Text.Encoding encoding).

Any movement on this issue?

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for considering Aspose.

Please try the attached latest fix of Aspose.Cells. Now System.Text.Encoding.Default will be used as encoding type if the encoding is not specified in the Workbook.Save method. Please do let us know if you still face any problem.

Thank you & Best Regards,