We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Unable to view the text content in msg file while setting image color compression as "None" and color reduction as"Black and White"

Hi,

When I tried to view the msg file as tiff file, the content with red color,yellow color are not displayed while I sett the color compression as "None" and color reduction as"Black and White". I am using Aspose.Words.Saving.ImageSaveOptions to set the tiff settings.

Please find the attached file.

Hi,


Thank you for your inquiry.

It seems that your inquiry is related to Aspose.Words component. That is why I am going to move the thread to appropriate forum (Aspose.Words forum) for further assistance.

Regards,

Hi Ponraj,


Thanks for your inquiry. I am representative of Aspose.Words team. Unfortunately, it is difficult to say what the problem is without the input msg file and code. I need this file and code to reproduce the problem on my side.

Moreover, it is safe to attach files in the forum. If you attach your document here, only you and Aspose staff members can download it. Also you can send the file to my e-mail as described here:
http://www.aspose.com/corporate/purchase/faqs/send-license-to-aspose-staff.aspx
You can also remove any sensitive information by replacing it with dummy data instead.

Best Regards,

I am unable to attach the .msg file. Let me explain the steps. Just open one outlook file and give the below text and save the file as .msg format.

Text with black color --Black color<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Text with red color. –red color

Text with yellow color. – yellow color

Text with brown color. – Brown color

Hope you have sample code to convert .msg file to tiff. In that set save options as below:

Color Reduction : black & white

Color Compression: None

Aspose.Words.Saving.ImageSaveOptions options = new Aspose.Words.Saving.ImageSaveOptions(Aspose.Words.SaveFormat.Tiff);

if (ColorReduction == ColorMode.BlackAndWhite)

options.TiffCompression = Aspose.Words.Saving.TiffCompression.Ccitt4;

options.ImageColorMode = Aspose.Words.Saving.ImageColorMode.None;

Thanks,

Ponraj.M

Hi Ponraj,


Thanks for your inquiry. I am transferring your thread to Aspose.Email where our team member representative can treat you very well.

Hi Ponraj,


I have verified at my end that Aspose.Email component is producing the mhtml just fine. Attached to my reply is the sample file required by my fellow colleagues from the Aspose.Words forum. They will look further into this matter.

We are sorry for this inconvenience.

Hi Ponraj,


Sorry for inconvenience. Please follow up this workaround:
(While using latest Aspose.Email & Aspose.Words)

MailMessage
msg =
MailMessage.Load(“d:/font.msg”, MessageFormat.Msg);

MemoryStream msgStream = new MemoryStream();

msg.Save(msgStream, Aspose.Email.Mail.MailMessageSaveType.MHtmlFromat);

msgStream.Position = 0;

Document msgDocument = new Document(msgStream);

msgDocument.Save("d:/font.tiff");

I have attached test files.

In case of any ambiguity, please feel free to ask.


Hi ,

I am also using to same code to save as tiff. But only the difference is I need to pass the saveoption parameter which is mandatory in my case. So please test by passing the saveopton parameter whit the values I provided earlier. Please let me know if any workaround by passing saveoptions.

Thanks,

Hi Ponraj,


Thanks for your details. While using saveption parameter, i could not reproduce the problem. Please make sure you are using latest AW & AE versions.
<span style=“font-size:9.5pt;font-family:Consolas;
mso-fareast-font-family:“Times New Roman”;color:#2B91AF;mso-ansi-language:EN-US;
mso-fareast-language:EN-US;mso-bidi-language:AR-SA”>
<span style=“font-size:9.5pt;font-family:Consolas;
mso-fareast-font-family:“Times New Roman”;color:#2B91AF;mso-ansi-language:EN-US;
mso-fareast-language:EN-US;mso-bidi-language:AR-SA”>ImageSaveOptions<span style=“font-size:9.5pt;font-family:Consolas;mso-fareast-font-family:“Times New Roman”;
mso-ansi-language:EN-US;mso-fareast-language:EN-US;mso-bidi-language:AR-SA”>
opt = new ImageSaveOptions(SaveFormat.Tiff);
msgDocument.Save(“d:/test.tiff”,
opt);

In case of any ambiguity, please let me know.

<o:p></o:p>

Please set the below values and try:

options.TiffCompression = Aspose.Words.Saving.TiffCompression.Ccitt4;

options.ImageColorMode = Aspose.Words.Saving.ImageColorMode.None;

Hi Ponraj,


Thanks for your inquiry. I managed to reproduce this issue on my side. I have logged this issue in our bug tracking system. Your request has also been linked to the appropriate issue and you will be notified as soon as it is resolved. Sorry for inconvenience.

Hi,

Any updates for me on this?

Thanks,

Hi Ponraj,


Thanks for your inquiry. Unfortunately, your issues are still pending for analysis. Once our developers analyze these issues, we will be able to provide you an estimate.Sorry for inconvenience.