We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Undelieved Message

Hi,


I am using Aspose.Email.dll (3.6.0.0) to generate .msg files from one of our product’s functionality, with FROM address set to logged in user, whose MS Outlook is configured with that email ID (abc@xyz.com).

MSG file is created successfully.

When the MSG file is opened in MS Outlook, the senders’ address is shown with a tooltip saying “send using accout: abc@xyz.com”.

When this email is send, it could not be delivered and a undeliverable notification mail comes saying: "You
can’t send a message on behalf of this user unless you have permission to do
so. Please make sure you’re sending on behalf of the correct sender, or request
the necessary permission. If the problem continues, please contact your
helpdesk.
"

When the same email address (abc@xyz.com) is selected from “From” dropdown list (in same window of the MS Outlook), the tooltip saying, send using account:, does not show up and everything works fine.

Is there anything while creating MSG file that can fix this issue?

Hi Dev,


Thank you for contacting Aspose support team.

I have tried the scenario using below mentioned code and opened the output files in Outlook 2013. The tool tip was displayed as mentioned by you on the from address and I just pressed Send button. I am afraid to share that I could not observe any issue and mails were sent successfully.

Could you please test the following sample code using latest release Aspose.Email for .NET 4.2.0 and let us know your feedback?

static void TestFromMsg2()
{
Aspose.Email.Mail.MailMessage message = new Aspose.Email.Mail.MailMessage();
message.From = "from@domain.com";
message.To.Add("to@domain.com");
message.Subject = “summary Mapi”;
Aspose.Email.Outlook.MapiMessage outlookMsg = Aspose.Email.Outlook.MapiMessage.FromMailMessage(message);
outlookMsg.SetMessageFlags(MapiMessageFlags.MSGFLAG_UNSENT);
outlookMsg.Save(@“UnsentMapi.msg”);
}

static void TestFromMsg()
{
MailMessage mail = new MailMessage("from@domain.com", "to@domain.com", “summary Mail”, “sample body”);
mail.Headers.Add(“X-Unsent”, “1”);
mail.Save(@“UnsentMail.msg”,MailMessageSaveType.OutlookMessageFormatUnicode);
}

Thank you, Kashif.


We tried with the version 4.2.0 and it worked.

Hi Dev,


Thank you for the feedback and if you have any other query/inquiry with respect to Aspose.Email, please feel free to write to us.