We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Unhide Objects and PPTX Issues

<span style=“font-size: 11pt; font-family: “Calibri”,“sans-serif”; color: rgb(23, 54, 93);” lang=“EN-US”>1.<span style=“font: 7pt “Times New Roman”;”>
<span style=“font-size: 11pt; font-family: “Calibri”,“sans-serif”; color: rgb(23, 54, 93);” lang=“EN-US”>Mark “Unhide
Shapes” to checked in test project and click “Run Test”, chose the ppt file

<span style=“font-size: 11pt; font-family: “Calibri”,“sans-serif”; color: rgb(23, 54, 93);” lang=“EN-US”>Expected that calendar should be visible
on slide “Februray 2010”. The calendar stays hidden

<span style=“font-size: 11pt; font-family: “Calibri”,“sans-serif”; color: rgb(23, 54, 93);” lang=“EN-US”>2. Unhide shapes does nothing <span style=“font-size: 11pt; font-family: “Calibri”,“sans-serif”; color: rgb(23, 54, 93);” lang=“EN-US”>for PPTX

Hi Kunal,

I am sorry for the delayed response.

I regret to inform you that I unfortunately unable to completely understand your problem statement. Can you please share some more information about your issue? I have used the source project with the shared presentation and have not been able to observe any effect in PPT when "Unhide Shapes" check is selected. In case of PPTX, I am receiving some error messages upon opening the presentation after the "Unhide Shape" operation has been performed for PPTX. Please share some further thoughts.

We are sorry for your inconvenience,

Hey,

Thanks for the response. So load up the powerpoint ppt file and go to the february calendar. You will see there is a toggle switch to show/hide the object. The object is hidden by default.

The sample code aims to unhide this object – a feat which does not seem to be working correctly.

Hi Kunal,

I have worked on the presentation files shared by you and have been able to reproduce the issue that Shape.Hidden & ShapeEx.Hidden properties don't seem to work in the scenario mentioned by you. It seems to be an issue with Aspose.Slides for .NET and in order to resolved the problem an issue with ID 18080 has been created in our issue tracking system. This thread has also been linked with the issue, so that you may be automatically notified, once the issue is resolved.

We are sorry for your inconvenience,