'Unknown cell spacing sides' error


#1

I am getting the following exception error when I try to open a Word document from a memory stream: Unknown cell spacing sides.

What does this error mean and how can I fix it? I have pasted my code below:

// Set license files for Aspose components...

Aspose.Word.License myWordLicense = new Aspose.Word.License();

myWordLicense.SetLicense(HttpContext.Current.Server.MapPath(HttpContext.Current.Request.ApplicationPath + "/Documents/AsposeLicenses/" + AsposeWordLicense));

WebClient myWebClient2 = new WebClient();

byte [] myPreviousBinaryData = myWebClient2.DownloadData(myFile.WorkingPath);

// Create stream from byte array...

MemoryStream myStream = new MemoryStream(myPreviousBinaryData, 0, myPreviousBinaryData.Length);

// Open the file in Aspose from the stream

Document myPreviousCertAsposeDoc = new Document(myStream); *** ERROR Occurs Here

spotvader


#2

Make sure you use the latest version of Aspose.Words. If that does not help, please attach your document to the forums and we will investigate. Maybe something in a DOC file that we never seen before.


#3

I have upgraded to the latest versions (Aspose.Words 3.5) and still get the same error. I have attached the source document that is causing the error.

spotvader


#4

Thanks for reporting this issue to us. The defect is logged as Issue #833.

We plan to fix it in the next release. A message will be posted here when fix will be available.


#5

The error has been fixed in Aspose.Words 3.5.2 which is currently available for download:

http://www.aspose.com/Downloads/Aspose.Words/3.5.2.0/Default.aspx