Unrecognized image type encountered during DOCX export with '.ico' image


#1

I have one document that document has one image ‘Image.ico’ format. I tried to export using Aspose.word, it’s shown exception like ‘Unrecognized image type encountered during DOCX export

Document doc = new Document(@"Icon.docx");
			MemoryStream streamDocument = new MemoryStream();
			doc.Save(streamDocument, SaveFormat.Docx);

File Input : Icon.zip (12.5 KB)

Please help us.

Thanks


#2

@msindia,

We tested the scenario and have managed to reproduce the same problem on our end. For the sake of correction, we have logged this problem in our issue tracking system. The ID of this issue is WORDSNET-19122. We will further look into the details of this problem and will keep you updated on the status of correction. We apologize for your inconvenience.


#3

@awais.hafeez,

We hope you are working on this work (ticket ID: ** WORDSNET-19122** ).

It’s possible to fix Upcoming version?

Sorry for the frequent interruption.

Thank you.


#4

@msindia,

We have already fixed this issue. Please upgrade to the latest version of Aspose.Words for .NET i.e. 19.10 as it contains the fix of your issue (WORDSNET-19122). Hope, this helps.


#5

@awais.hafeez,

Thanks for your support. We will check and update the status.

Thanks.


#6

@awais.hafeez,

The ticket ’ ** WORDSNET-19122 ’ is solved. Thanks for your support :muscle:.

Thanks.


#7

@msindia,

Did you mean WORDSNET-19122? If yes, then thanks for your feedback on the linked issue i.e. WORDSNET-19122. In case you have further inquiries or need any help in future, please let us know.


#8

Yes.
Sorry for the wrong ticket. Now I modified.

Thanks


#9

The issues you have found earlier (filed as WORDSNET-19122) have been fixed in this Aspose.Words for .NET 19.10 update and this Aspose.Words for Java 19.10 update.