Free Support Forum - aspose.com

Updated from 4.1.0.0 to 5.6.0- now PDF merging is broken

After updating the PDF DLL, merging that once worked flawlessly now produces PDF documents where the text in the fields are several pixels up higher, cutting off the tops of the characters.

Randomly, some pages in the PDF that should be merged against have all of their merge fields removed. By randomly I mean, every single time the document is produced, at least one, sometimes multiple, pages have had their merge fields removed. To add to this bad situation, this only happens on certain machines.

Hi Sam,

Please share the following details with us, so we would be able to investigate the issue at our end:

  • Input PDF files
  • The code snippet
  • .NET Framework version
  • OS
We’ll look into this issue in detail and update you with the results accordingly.

We’re sorry for the inconvenience.
Regards,

Unfortunately I’m no longer able to reproduce the problem. The only machine that this occurred on was a VMWare virtual machine running Windows 2008 R2. I’m unable to share the PDF files in question.

Sadly, I’m afraid I’m just going to have to just drop the issue. We rolled back to using the old DLL.

Hi Sam,

I would like to share with you that we have introduced a merged Aspose.Pdf for .NET version recently. You may try it at your end and see if it helps in your scenario.

If you find any further questions, please do let us know.
Regards,

I’m back! After upgrading again to 5.7.0, the problem exists on all machines! And I have a demonstration solution to show the issues. Sorry for the vagueness of the first post, but that was as much as I knew at the time.

I have included a console solution demonstrating the problem. Simply compile and run, and then view output.pdf.

Here are images demonstrating my problems. Demonstrating problem 1: the text is slightly higher than it should be.

http://www.gamedesignforcherrytea.com/AsposeDemo/TextMoves1.png

Now, look at how it should be displaying:

http://www.gamedesignforcherrytea.com/AsposeDemo/TextMoves2.png

the text returns to the position it should be after editing the field (say, remove a letter), and replace it.

Next, problem 2 is a much more serious one. Sometimes, randomly, pages will be missing, and their merge fields will be removed. Notice in this image, “Highlight Existing Fields” is on, and there are no fields:

http://www.gamedesignforcherrytea.com/AsposeDemo/MissingMergeFields.png


Thank you for your help.





Hi Sam,

I have reproduced the first problem at my end and logged it as PDFKITNET-29440 in our issue tracking system. Our team will look into this issue and you’ll be updated via this forum thread once it is resolved.

However, I couldn’t notice the second problem. In fact, the fields are not removed, it’s only that they’re not highlighted. So, when you click the ‘Highlight Fields’ option, they look fine. I think, in the second case that button might have been clicked. However, if that’s not the case then please help us reproduce that issue as well.

We’re sorry for the inconvenience.
Regards,

I see that they are indeed not being highlighted, but are still there. However, some of my pages are definitely not filled out. Are you telling me you are seeing 15 pages of the same exact strings being merged into all of the fields? Every type I run this, different pages have missing fields. For example, in this case I’m missing pages 2 and 6. Try running the program again, because every time this is different.

Hi Sam,

Thank you very much for sharing further details. Now, I’m very much clear about the exact situation of this issue and I have reproduced it as well. I have also logged it as PDFKITNET-29452 in our issue tracking system. You’ll be notified once it is resolved.

We’re sorry for the inconvenience.
Regards,

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan