Free Support Forum - aspose.com

Upgrade compatibility

Hi there,


I purchased and have been using Aspose.Slides version 6.1.0.0 for some time now. I see that there is a newer version of the dll available - 7.2.0.0 which I have downloaded and replaced the reference in my solution to this dll.

It all seems to be working fine with the newer version but just wanted to be sure that there is nothing I need to purchase to deploy to live environment. Are the license keys/signature ok with this newer version?

Many thanks

Gursoy Galip

Hi Gursoy Galip,


I like to share that you are entitled for all of product released that have been shared online before expiry of your subscription. You can check the subscription expiry date by opening your license file and look for tag. You will see the expiry date mentioned in yyyymmdd format. Any product release shared before the mentioned expiry date in your license will be used on your end without any issue. Otherwise, you will get an exception message as well on your end if you are not entitled for the new product.

Please share, if I may help you further in this regard.

Many Thanks,