Free Support Forum - aspose.com

Upgrade to Aspose.Cells 20.7

@paulo_pereira,

If you allow we can make the thread public for the time being, so @Hugo_Freixo could access this thread, please confirm?

Hi @Amjad_Sahi,
Yes, this post can be public.
Also did you have tested this with JDK8?
We have some urgency to fix this problem. Are you able to a share screen meeting in order to clarify the issue?
Kind regards,
Paulo Pereira

@paulo_pereira,

We have made this thread public.
We will evaluate your issue further and get back to you with more details (if possible).
By the way, which version of the sdk you are using? If you are not using the latest version of the sdk or the same maven, please upgrade to latest version and try again and let us know.

@paulo_pereira,

Please note, we are using JDK8. Here are some screenshots (attached) for the building process. With the default memory limit(768M), we got the same OutOfMemoryError with user(screen_768M.png). When we change the limit to 1024M, we get the project built successfully(screen_1024M.png).
screen1.png (48.0 KB)
screen2.png (36.7 KB)
screen4.png (64.5 KB)
screen3.png (47.3 KB)
screen_1024M.png (41.1 KB)
screen_768M.png (49.2 KB)

Hi @Amjad_Sahi,
This thread is still private, my collegue @Hugo_Freixo does not have access to this post.

Also we’ve been in contact to the Atlassian team, in order to fix this. We found a solution for the version 20.7 of your products upgrading maven and amps.
But, with the same solution, upgrading to the lastest version of aspose products produce the same error.

Are yours jars growing a lot in every version released?

Can you help us with a solution for this?

Kind regards,
Paulo Pereira

@paulo_pereira,

Could you check it now.

There might be small increase in size (not significant though), you may check previous release notes for API changes we have made for last few versions.

As we are still unable to reproduce the issue on our end, but still we will check if something can be done. Once we have an update on it, we will let you know.

Hi guys,

You have to help us get this working.
We should schedule a call to discuss this issue.
Our timezone is UTC +0 (Portugal).
When can we meet?

Best regards,
Hugo Freixo

@Hugo_Freixo,

I am afraid, we do not provide technical support via phone. The best way to get technical support speedily is using forums.

We are evaluating your issue further. What is the solution you used to solve your problem with 20.7, please elaborate and give complete details? It might give us some hints for the problem. Please note, since we cannot reproduce the issue and have no idea/clue about the reason what so ever. We are afraid we cannot provide solution for it unless we reproduce the issue on our end. During the evolution we may support more and more new features, so it is reasonable/understandable that our component may become larger and larger in new versions.

We were able to compile a little example project using atlas-mvn and Aspose 20.7 by upgrading amps version from 8.0.0 to 8.2.0 and forced atlas-mvn to use maven 6.3.6 with mvnvm.
Also, we added this to the pom:

<plugin>
<artifactId>maven-jar-plugin</artifactId>
<version>3.1.2</version>
<configuration>
    <excludes>
        <exclude>**/module-info.class</exclude>
    </excludes>
</configuration>

We are not talking about a phone call, but a meeting using GoToMeeting or a similar call app (we should be able to share our screen)

Best regards,
Hugo Freixo

@Hugo_Freixo,

Thanks for providing more details and pom.xml contents. Please spare us little time to evaluate it thoroughly.

Net meeting is not possible too. you may compile screenshots and share with us here.

Also, we talked with Atlassian and they said this:

I think these errors are happening because the new versions of your aspose-* 
dependencies were built using JDK 9, and the older versions of tools like AMPS and 
Maven do not correctly handle the new files introduced in that version of the JDK
(especially module-info.class, which is weird in that it has no superclass).

then they told us to update maven and amps versions.

I’m sharing this hoping it can give more clues on what the problem is.

Best regards,
Hugo Freixo

@Hugo_Freixo,
We have recorded this information with the ticket and will share our feedback after analysis.

@Hugo_Freixo,
Please try the new version of our products one by one to see whether all products cause such problem or just some special one causes it. For example, you may upgrade Aspose.Cells to latest version but keep Aspose.Words and Aspose.Pdf as the old versions which worked fine before, and then upgrade words only and try again, and then Pdf.

Let us know your feedback.

Hi guys,

We started upgrading Aspose version one by one and got these results:

RUN CELLS WORDS JDK16 PDF RESULT
#1 19.2 18.10 19.1 PASS
#2 20.1 18.10 19.1 PASS
#3 20.7 18.10 19.1 PASS
#4 20.10 18.10 19.1 PASS
#5 20.10 18.12 19.1 PASS
#6 20.10 19.2 19.1 FAIL
#7 20.10 18.12 19.1 FAIL
#8 20.10 18.12 19.1 PASS
#9 20.10 19.2 19.1 PASS
#10 20.10 20.1 19.1 PASS
#11 20.10 20.7 19.1 PASS
#12 20.10 20.10 19.1 FAIL
#13 20.10 20.10 19.1 PASS
#14 20.10 20.10 20.1 FAIL
#15 20.10 20.10 20.1 FAIL
#16 20.10 20.10 20.1 FAIL

Notice that FAIL means it failed with the Java heap space error reported previously and that sometimes the same versions can FAIL or PASS (we changed nothing, we simply tried to compile again).
The last runs always fail when we upgraded Aspose PDF to 20.1.

@Hugo_Freixo,
Thank you for the feedback. We are analyzing this information here and will share our feedback at the earliest.

@Hugo_Freixo,

It seems the different memory cost was mainly caused by Aspose.Pdf component. So we think it will be better if Aspose.Pdf team can investigate this issue further, especially the “module-info.class” you mentioned. You may post your issue in Aspose.PDF forum with all the details and resources. On the other hand, we think supporting and using higher version of JDK is necessary for all our components sooner or later, so the ultimate solution for your problem should be provided by the tools such as Atlassian SDK, AMPS and Maven (make them fully support higher versions of JDK such as JDK9).