We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Upgraded form 17.2 -> 19.5 and removing 'bookmarks' no longer works

I’ve attached a document that no longer works in version 19.5. We have some code that processes bookmarks and determines whether or not to remove. We followed the logic in this post: Proper way to remove bookmark and content?

So to start, any bookmarks in the word document that are not going to be processed (removed via logic above), I simply call Bookmark.Remove(). Then for all the remaining ones where I need to really remove the bookmark and the content I do the logic from above.

For the document attached, we’d simply remove the bookmark opt_A_popup (leaving the content), then try to remove the opt_A_wo_popup (and it’s content).

On version 17.2, the result looked like this (the first column in the Actuary Adjustment row):

image.png (21.2 KB)

Now in 19.5, the result looks like this:

image.png (22.1 KB)

So in addition to the value not being displayed (b/c I think the content of opt_A_popup is being removed), you can see the columns of the table are shifting a bit as well for some reason.

Do you see anything wrong with the two bookmarks mentioned (that are side by side in the document) or able to explain why it worked before and no longer works?

Thanks,
Terry

UPDATE: I can’t upload my word document. Is that possible so you can review my document?

@terry.aney,

Thanks for your inquiry. Have you tried the latest version of Aspose.Words for .NET i.e. 19.7 on your end? In case the problem still remains, please ZIP and upload your input Word document, Aspose.Words 17.2 generated output file showing the correct result, Aspose.Words 19.7 generated output file showing the undesired behavior and a simplified console application that helps us to reproduce your problem here for testing. We will then investigate the issue on our end and provide you more information.

P.S. You can also upload the ZIP file to Dropbox and share the Download link here for testing.