We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Upgraded .lic file throws "the license is not valid for this product" error

Hi,

We had recently upgraded the Aspose.Total.Lic file since our subscription expiry date has ended. However, once we had updated from LicenseVersion "2.2" to "3.0", we started receiving the error - "the license is not valid for this product"

Other Details:

Product: Aspose.Total for .NETAspose.Total for .NET

Edition Type: Enterprise

Aspose.Pdf.Kit.dll - File version - 4.9.0.0

Aspose.Pdf.dll - File version - 3.4.0.0

.Net Framework Version - 4.0

We just dropped the new .lic file instead of the old one and started receiving the error. Appreciate your prompt response.

Thanks,

Kalyan B

Hi Kalyan,


Thanks for contacting support.

The versions of product API’s which you have stated are quite old and also please note that since July-2011, Aspose.Pdf.Kit for .NET has been discontinued as separate product and all its classes and enumerations are merged under Aspose.Pdf.Facades namespace of Aspose.Pdf for .NET API.

I would recommend you to please download the latest release of Aspose.Pdf for .NET 9.3.0 and your license should work with this new release. In case the problem still persists, please feel free to contact.

You may also consider visiting following links for further details on