We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Upgrading to .net 6.0 throwing Exception on line license.SetLicense("Aspose.Total.lic");

After upgrading to .net 6.0, getting error on line
license.SetLicense(“Aspose.Total.lic”);

I am using ASPOSE.PDF version 20.3.0.

@bhartigupta

We would like to share with you that license setting issue under .NET Core 6.0 was resolved in 21.11 version of the API. Please upgrade your API to 21.11 or the latest version in order to prevent the issue.

Do I need to buy the license for it again if I upgrade the API to 21.11 from 20.3?

@bhartigupta

Yes, you need to re-new your license in order to use the latest version. The existing license will be valid for the API versions which were released before the subscription expiry date of the license. Also, we always recommend using the latest version of the API as it contains maximum improvements and fixes. Please feel free to let us know in case you need more information.