We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Urgent issue - Aspose .csv export different to Excel's

Hi! I have a spreadsheet which, when saved to CSV through Excel, a number of commas are left on the ends of each field to indicate blank rows. However, when I save with aspose, those are stripped off.

See the attached files to see what I mean. I need those extra commas to preserve the format! (it isn’t a standard CSV, its a catalogue file for a system). In truth its only the extra commas between the DATA and ENDOFDATA sections I really need the commas for - but the number of them will differ according to the number of fields there are and how many fields are blank, so I’d rather not hack the code around to add them manually.

It’s kind of like the opposite of the ‘treat consecutive delimiters as one’ option when you import a CSV file - the export should do the same as Excel unless an option is set otherwise.

I’d really appreciate your help!

Many thanks

Mark

Hi Mark,

We found the issue as you have mentioned. We will fix it soon accordingly as MS Excel does put some extra commas you mentioned.

Your issue has been logged into our issue tracking system with an issue id: CELLSNET-18012.

Once it is figured out we will let you know.

Thank you.

Hi,

Please try the attached version v5.0.0.4. We have fixed your issue.

Thank you.

I really can’t express how amazing you guys are to identify and fix it so quickly: thanks so much! I’ll be trying this asap, and again I appreciate your help enormously!

Mark

Gave this a test, works like a charm! Thanks again!!

The issues you have found earlier (filed as 18012) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.