We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Users are getting "Powerpoint file is unable to display . . " corruption error when opening in PPT 2007

I am using aspose.slides version 6.8 and I created a template powerpoint presentating in ppt 2010

"Powerpoint was unable to display some of the text, image, or objects on slides in the file "XYZ.pptx" because they have become corrupted. Affected slides have been replaced by blank slides in the presentation and it is not possible to recover the lost information. To ensure that the file can be opened in previous versions of powerpoint, use the "Save as" command (File menu) and save the file with either th esame or a new name"vand when users load the presentation that are on powerpoint 2007 they get this error

My guess is that this has to do with a recent change to dynamically add images to my slides using this code:

using (FileStream stream = new FileStream(_headerImage, FileMode.Open, FileAccess.Read))
{
var img = Image.FromStream(stream);
_imgx = destinationPresentation.Images.AddImage(img);
}


and then adding the picture like this . .

private void AddPictureFrame(SlideEx slide, float currentY, int height)
{
var idx = slide.Shapes.AddPictureFrame(ShapeTypeEx.Rectangle, HEADING_LEFT, currentY, HEADING_WIDTH, height, _imgx);
var picFrame = slide.Shapes[idx];
picFrame.LineFormat.FillFormat.FillType = FillTypeEx.NoFill;
slide.Shapes.Reorder(0, picFrame);
}


this works great when i open it up in powerpoint 2010 but when i open it up in 2007, i get this error:



Any suggestions on how to resolve?



Hi Adam,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for the details.

Please download and try the latest version of Aspose.Slides for .NET v8.4.0 and see if it works fine for you. In case you still face the issue, please share your template and generated presentation files along with complete sample code to reproduce the issue. We will check it and get back to you soon.

Sorry for the inconvenience,

are you saying this is a known issue and its fixed in the latest version ? or are you just saying to see if I still see the issue in the latest version because I tried and I still get the same error with the newer version of aspose.slides

Hi Adam,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for the feedback.

We suggested to test with the latest version because you are using an older version of the API and a lot of improvements and bug fixes are done after that version, so it is possible that the issue you are facing might also got fixed between these version. Also, all the testing and fixes at our end are done with the latest version, so we always recommend the users to try the latest version.

Now, as you are still facing the issue, please send us your template input and generated output file with complete sample code to reproduce the issue at our end. It will help us in identifying the cause of the issue.

Thanks & Regards,

So it turns out that it might have nothing to do with the image code above as I removed that code and users of powerpoint 2007 are still having the issue. So it seems to be a more generic issue around using a template that was created in 2010 and having users load it who are on 2007. Is that a known issue at all?

I have updated the above question to focus on the issue and restating that the "image" code was just a theory on why the issue could be happening.

Do you have any suggestions on why users of Powerpoint 2007 would get that issue listed above?

Hi Adam,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Well, as you have stated that the template file is generated with PowerPoint 2010 and users of PowerPoint 2007 are facing the issue, so it might be possible that some feature which is not supported in 2007 or has been changed in PowerPoint 2010 is causing the issue while opening the file in PowerPoint 2007. However, we don't have sufficient information to give any further insights on this. As I requested before, please share the sample file and your code with us, so we can further investigate your issue and help you further.

Thanks & Regards,