We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Using Aspose.pdf 8.3 to downgrade PDF files to v1.4- error 107 when open with Acrobat 5.0

Aspose support,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Currently I am helping my company with PDF downgrade, we only have Acrobat 5.0, which only reads

PDF version 1.4.

We downloaded your latest aspose.pdf 8.3 and acquired a temp license.

I used the following code to downgrade the PDF files of version 1.5 - 1.7 to version 1.4.

After finished the downgrading, we opened some files (especially those downgraded from v1.6) with Acrobat 5 and got error message shown in the attached file 'error.jpg'

"There was an error opening this document. There was a problem reading this document(107).

-------------------------------------

Aspose.Pdf.Document pdfDocument = new Aspose.Pdf.Document(@"C:\Temp\pdf16.pdf");

pdfDocument.Convert("log.xml", PdfFormat.v_1_4, ConvertErrorAction.None);

// save the updated document

pdfDocument.Save(@"c:\temp\downgraded.pdf");

pdfDocument.Dispose();

Can you review my code and advise what I can do?

Regards,

clin1

Hi there,


Thanks for your inquiry. Can you please share some problematic PDF files(v1.6) here? So we test the scenario at our end and will provide you more information accordingly.

Moreover, please also confirm whether 1.5 and 1.7 conversion working fine?

We are sorry for the inconvenience caused.

Best Regards,