Free Support Forum - aspose.com

Using (skip:n) at the end of dynamic formulas

Hi

I have a spreadsheet that has about 21 columns. Out of those 21 columns, 4 have dynamic formulas that look something like &=&=if(M{r}="","",IF(N{r}="","",M{r}-N{r})) or similar. I have the standard smart markers setup similar to &=[newtable].[first name]. When I add the (skip:n) to the end of my smart markers, &=[newtable].first name I have no problems with the output. However, when I place the (skip:n) at the end of my formula &=&=if(M{r}="","",IF(N{r}="","",M{r}-N{r}))(skip:1) I get something like the one below…

12
0
22
0
31
0
etc…

Because I have told it to skip 1 row after the record the forumla isn’t skipping. It is still being copied down. Does anyone know how I prevent the formula being copied in the cells in the blank rows? Or is this a bug that needs to be addressed?

Hi,

Well, dynamic formula with skip:n attribute is not supported, We will soon look into it.

Thank you.

Hi,

Please try this fix.

In order to distinguish smart marker option from the parms of MS Excel Function, please add "~" before smart maker option.such as:&=&=if(M{r}="","",IF(N{r}="","",M{r}-N{r}))~(skip:1)