We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Using skip row smart marker in aspose.cells for reporting services


in the documentation for .NET you mention that you can skip rows using the following code:


This does not seem to work in the version for reporting services:
The Value expression for the textrun ‘D01REV_9_1.Paragraphs[0].TextRuns[0]’ contains a colon or a line terminator. Colons and line terminators are not valid in expressions.

What is the correct way to write this formula in aspose.cells for reporting services?




Thanks for using Aspose APIs.

Please share your RDL files with and without skip rows and their exported Excel files for investigation. We will look into them and help you asap.

@shakeel.faiz please find an example attached. I cannot add an example with the skip as aspose does not save files that contain errors. I have attached an output with the result of what I am expecting.


Charlesgroup.zip (29.5 KB)


Thanks for your sample RDL and sample Excel files.

We have logged your requirement in our database for evaluation and investigation. We will look into it and help you to deal with this issue. Once, we will have some news for you, we will help you asap.

This issue has been logged as

  • CELLSRS-525 - Using Skip Row Smart Marker in Aspose.Cells for Reporting Services

Just to let you know that I have been running more tests, even by not using the ##group tag, but in this case it seem ASPOSE assumes I want to return the data down the columns and just repeats all the data multiple times.

Ultimately I would like to return multiple rows of data per “database line” in order to present the data in a easier format to read and have all the secondary lines grouped together (not through 7 different levels)

What I don’t seem to understand is that by using the group tag, it also hides the primary line no matter where I start the tag, when I would expect the top line to always be visible and the + to be added only for the lines that have a group tag.



Thanks for your posting and considering Aspose APIs.

Grouping seems to be working fine as I have checked your previous Excel file as shown in the following screenshot.

Please highlight your issue with some screenshots and related RDL files. Besides, it seems, your current issue is not related to Smart Marker and it is only related to grouping. Please clarify. We will then log a separate ticket based on your provided information.


@shakeel.faiz which codes did you run to obtain this output?


I am referring to the following post and its attachment. i.e.group.zip

I do not get this at all when I run the sample code I gave you hence my ticket, did you make any changes to the code I provided to have it output this way?

EDIT: I couldn’t believe my eyes that it worked for you since I must have spent 6 hours on this already trying to get it to work so I tried to run it again on my end but I can confirm it does not work (took a screenshot but cannot figure out hot to embed an image on the forum)

the grouping is all wrong on my end, what did you change in the code?


Please spare us sometime, we will update you regarding the grouping in next few days.


Thanks for using Aspose APIs.

We are unable to open your provided RDL file. The Excel file I shared earlier with you was provided by you which I mistook as your actual output but it was your expected output which you created manually.

However, when we tried to open your RDL file i.e. grouptest_.rdl in Aspose.Cells for Reporting Services Client Tool or Microsoft Excel 2016 Add-in, it did not open up.

Please check the sample RDL files and their screenshots. As you can see, Company Sales.rdl from Aspose is opening fine but grouptest_.rdl is showing error.


We tried to open the report definition file. But we could not use Aspose.Cells for Reporting Services Client to open the report definition file in MS-Excel.

Please share with us how did you create the report definition file?

RDL Files:
RDL Files.zip (70.7 KB)

screenshots.zip (375.1 KB)

@shakeel.faiz I used Aspose but the Addin is not very stable and I receive a lot of errors (when opening new windows or other) I sometime lose all my work and need to start over.

I have redone a new test version for you

grouping.zip (24.7 KB)


Thanks for the good RDL file, it opens fine as shown in the following screenshot.

We have logged your comment and RDL file for further investigation. We will update you tomorrow hopefully.


For your issue CELLSRS-525,

Please download and try the following fix and let us know your feedback.

If you use the 64 bit Excel, you need to manual register Aspose.Cells.ReportingServices.dll.


C:\Windows\Microsoft.NET\Framework64\v2.0.50727\RegAsm.exe  "C:\Program Files (x86) \Aspose\Aspose.Cells for Reporting Services\Bin\Aspose.Cells.ReportingServices.Client.dll"  /tlb Aspose.Cells.ReportingServices.Client.tlb /codebase

dear @shakeel.faiz,

would you be able to provide an example on how to write the parameter in Excel?




Sure, we will look into it and provide you an example hopefully. We have also recorded your request. Once, we will have some update for you, we will let you know asap.


Please note,

  • Aspose.Cells for .NET supports the Smart Marker parameters.
  • But Aspose.Cells for Reporting Services does not support it.

However, Aspose.Cells for Reporting Services some other types of parameters (i.e. Query and Report Parameters) as discussed in this document.

@shakeel.faiz so how should I test? You mentioned in your previous post that the issue had been fixed.



We are sorry for the confusion, we misconstrued this issue. Please disregard the previous fix.

The correct information is provided in post #17.

@shakeel.faiz the document you attached does not have information on skip row. could you please include an example on how to use skip rows within the parameters document?