We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Validations do not work in XLSB format

Aspose Team,


I am running into another issue when saving an Excel document in XLSB format. Validations do not seem to work.

The result should be that when adding a negative number or non-numeric value to any cell in the first row a validation message pops. Works great in XLSX, but does not work at all in XLSB.

This is somewhat similar to an issue posted earlier this week regarding Excel formulas: SUMIFS Excel function does not work in XLSB format

I’m using the .NET v8.6.1.0 version of Aspose.Cells.

Thank you.

Hi,


Thanks for providing us sample project.

After an initial, I observed the issue as you mentioned by using your sample project. I found that Validations are not applied and do not work in XLSB format, it works fine in XLSX file format though. I have logged a ticket with an id “CELLSNET-44034” for your issue. We will look into it soon.

Once we have any update on it, we will let you know here.

Thank you.

Hi Tim,


This is to update you that we have fixed the problem logged earlier as CELLSNET-44034. We will shortly provide the fix here after ensuring the quality, and incorporating other enhancements. As soon as the next build of Aspose.Cells for NET API is available for your testing, we will notify you in reference to aforementioned tracking number.

Hi,

Thanks for your using Aspose.Cells.

Please download and try the latest fix: Aspose.Cells for .NET v8.6.1.2 and let us know your feedback.

The issues you have found earlier (filed as CELLSNET-44034) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.